Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried PCManFM too, same thing. Windows Explorer on Windows 7 can load the directory, thumbnails and all, in as little as 30 seconds or so. In Nautilus, it's constantly jostling around all the images and this goes on for about 20 minutes and finally it stops. Scrolling through is terribly slow, too and silky smooth on Windows 7. I'm using both Operating Systems on an SSD drive. How can I rectify this problem?

share|improve this question
We cannot answer non-constructive questions like this. If you’d formulated your question like: “How can I improve Nautilus’ performance”... – fitojb Dec 23 '11 at 20:13
I fixed the title. – tupperware Dec 23 '11 at 20:21
I use Nautlius on a slow POS netbook and it behaves nothing like what you described, something else is wrong with your Installation. – Uri Herrera Dec 23 '11 at 22:39
You may have to use some SSD specific tools. – Uri Herrera Dec 23 '11 at 22:40
It sounds like a bug. Can you post your system specs, so this can be reported to the Nautilus developers? – fitojb Dec 24 '11 at 2:36

Since the problems happens to multiple file managers, it might be likely that it's a filesystem problem. Try adding disabling access time (add noatime to fstab), and if you're using ext4, try disabling write barriers (add barrier=0 to fstab).

The noatime flag tells the filesystem not to record the last access time. Recording access time means that even opening a file will cause an unnecessary write operation; most program never use access time and so it usually can be safely turned off nowadays.

Secondly, write barrier in ext4 prevents data loss under very specific circumstances, although it comes with a performance penalty to certain write-intensive applications. Write barrier is new in ext4, so if data reliability like in ext3 is good enough for you, then you can turn off write-barrier.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.