Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 11.10 4 days ago. When I login into my account the startup/login sound does not play. But when I logged in with a guest account, the sound plays. This is happening since I installed ubuntu 11.10, I never heard the login sound when I log into my account. And by the way, this is a fresh install. Please help.

share|improve this question
    
I've just had a look in the startup applications, and "GNOME Login Sound" is checked... So why doesn't it play? –  ATRus747 Dec 23 '11 at 15:12
add comment

3 Answers 3

up vote 8 down vote accepted
sudo cp /usr/share/sounds/ubuntu/stereo/* /usr/share/sounds/

Do this in a terminal and your login sound should play. The above command copies the content of directory /usr/share/sounds/ubuntu/stereo to directory /usr/share/sounds

share|improve this answer
1  
That works! Thanks! –  ATRus747 Dec 23 '11 at 18:43
    
You are welcome. :) –  Atem18 Dec 24 '11 at 11:46
    
Could you explain what you are doing here? (add it to your answer please). Related LP question: answers.launchpad.net/ubuntu/+source/libcanberra/+question/… –  Lekensteyn Feb 24 '12 at 9:54
add comment

When you are logged in with your user, take a look into Startup Applications inside the Ubuntu Configuration and check if the login sound was disabled. This documentation is a bit old, but it shows how the Startup Applications program looks like.

https://help.ubuntu.com/community/AddingProgramToSessionStartup

share|improve this answer
    
Login sound is already checked in the Startup applications menu... –  ATRus747 Dec 23 '11 at 17:08
add comment

There are several possible reasons, check these.

  1. The sound may be muted or has been set to zero value.

    For this, look in the top right corner, click on the sound icon, and raise your sound volume.

  2. The login sound could be disabled from Startup Applications. It can be found in the top right corner of your screen in the same menu as Log Out.

    For this, verify that a check mark is there on gnome login sound.

Or if you changed something accidentally and don't know what you changed, then use this method.

  1. Install dconf Editor from ubuntu software center, and run it.
  2. Go to org/ gnome/desktop/application/sound.
  3. Point your cursor to event-sounds, and below dconf editor there is a Set to Default option. Click on it.
  4. Log out and log in to your account.
share|improve this answer
    
Tried all you said: - Volume is at maximum and not muted - I the Startup applications, login sound is checked - and finally, using dconf editer didn't change anything: still no sound at startup... Except that, i can hear music, YouTube video sounds, and everything else... –  ATRus747 Dec 23 '11 at 17:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.