Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Originally using Ubuntu 11.10 64-bit (Kernel 3.0.0-14-generic) . As there are heating issues with the kernels, i installed kernel 2.6.38.10-kernel also. When i boot using 2.6 kernel, the wifi doesnt work, but in 3.0 it does.

I'm a beginner at Ubuntu so please be precise.

share|improve this question
add comment

2 Answers

OK not a direct answer to the wlan question, however, I understand your situation as follows, that you switched to the older kernel due to heating problems. Try to install Jupiter, which is solving some of the regression issues leading sometimes to overheating. If so, you can use the newer kernel which supports your wlan.

Jupiter how to

share|improve this answer
    
dago, i did performed some tweaks on the 3.0 kernel, but still its heating more than 2.6. Is there any way to enable the wifi in 2.6 kernel, the same is working in 3.0 kernel ? –  Novice User Dec 23 '11 at 3:56
add comment

If you are a beginner to Ubuntu, I wouldn't recommend installing alternate kernels (that's quite advanced hackery). The default kernels are fine.

But to really answer your question, broadcom wireless cards need firmware to work. You can download this firmware (when connected to the Internet by another means, such as a wired LAN connection), by installing the "firmware-b43-installer" package. Or you can do this via the "Additional Drivers" control panel widget.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.