Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following /etc/samba/smb.conf config setup to share my homes and a custom folder named /var/itc_data_feed:

[homes]
   comment = Home Directories
   browseable = yes
   read only = no

[itc_data_feed]
   comment = ITC_DATA_FEED
   path = /var/itc_data_feed
   read only = No

After editing this file I restarted smbd with the following command:

sudo smbd reload

I would expect to be able to access these on windows OSs through Start->Run: \\myservername\someuser or \\myservername\itc_data_feed but neither are working.

What am I missing or doing wrong?

UPDATE

It seems that I cannot connect using the servername but rather I must use IP address. Once I use IP address I am asked to authenticate with my linux credentials; however, I am wanting an open share that does not require authentication.

To achieve this I intentionally omitted the valid users line but I am still being asked to authenticate, why is this happening?

share|improve this question
    
Barely on topic but I think you want writable = yes instead of read only = no. You might also eventually (once it's working) want valid users = %S to limit access to homes based on the samba user. –  Oli Dec 22 '11 at 14:35
    
@Oli, please see my update in my OP –  sadmicrowave Dec 22 '11 at 14:42
add comment

1 Answer

up vote 1 down vote accepted

Looks like I may have solved my problem:

my smb.conf now has these changes in the following sections:

security = share

create mask = 0757

[itc_data_feed]
  comment = ITC_DATA_FEED
  path = /var/itc_data_feed
  writable = yes
  browsable = yes
  guest ok = yes
  create mask = 0757

these settings allow me to connect directly to the /var/itc_data_feed share without needing to authenticate and gives the user read/write permissions in the directory.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.