Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I installed Ubuntu server, and connected to my wireless by following this steps:

$ ifconfig wlan0 up

$ sudo /etc/init.d/networking stop

$ wpa_passphrase "ssid" "password" > wpaconfig

$ sudo wpa_supplicant -iwlan0 -cwpaconfig

Press ctrl+z

$ bg

$ sudo dhclient wlan0

Credits for this instructions goes to this site.

I am able to connect, but on reboot I have to repeat all the steps, even though it is simple and straightforward, I would prefer if I could connect automatically.

How can I achieve this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Two options :

wicd

Use wicd-cli

sudo apt-get install wicd-cli
wicd-cli

wicd is a command line, menu driven (ncurses) configuration tool

enter image description here

Proper configuration

Normally you configure your wireless in /etc/wpa_supplicant/wpa_supplicant.confand /etc/network/interfaces

It varies a little depending on your wireless router. There is a great post on the Ubuntu Forums Wireless Security that goes through the various configurations (PSK, etc).

There is also the Ubuntu Wiki WPA page, but as you can see it could use a little love.

If you need assistance with configuration, we need a little more information about your network.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.