Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried connecting a Nikon P7100 camera to a USB-port on two different laptops running Ubuntu 10.04 and 11.04 but nothing happens. The camera says it's got MTP/PTP protocol. So it doesn't work as a mass storage device it seems. I can find no setting for changing the mode in the camera.

lsusb gives: Bus 002 Device 007: ID 04b0:018b Nikon Corp.

Is it possible to mount this camera somehow?

share|improve this question
add comment

2 Answers

Using Usb_modeswitch as discussed above won't work, but there are some alternative ways of accessing your photos , at least one of which should work for you:

On some cameras (like my friend's Nikon D70) there is an option on the camera that allows you to connect it to the computer as a mass storage device. However, on your P7100 I don't think there is that option after looking through the specs listed at the official site and studying the manual.

However, there is one option that might work for you; as you know your camera is a MTP device you could try mounting it manually with gvfs-mount and the gphoto2 protocol which has support for MTP devices. All you need to do is find (as you have done already) the usb bus location of your camera (i.e. the two numbers: Bus 002, Device 007), although that will probably change every time you connect your camera, so remember to check with lsusb. Enter, for example:

gvfs-mount gphoto2://[usb:002,007]

Then the camera should be available for you to import pictures via applications like gthumb, or at the very least you will be able to browse the .gvfs folder where it is mounted (enable hidden files in your file browser to see the .gvfs folder).

For Ubuntu 12.10 and later: the ~/.gvfs folder is now at /run/user/username/gvfs.

If the mount does not succeed, you could obviously take the memory card out and place it in a card-reader, but perhaps that is not what you want to do.

share|improve this answer
add comment

Look at the last several lines of the output of the dmesg command 10 seconds after you connect the camera. It should show something. Also try df -h to see if it's mounted.

Try usb_modeswitch. Read man usb__modeswitch. If you don't have usb_modeswitch, it can be installed via sudo apt-get install usb-modeswitch{,-data}.
Note: The program name is usb_modeswitch, but the package name is usb-modeswitch.

man usb_modeswitch says, in part:

   On  Linux,  in  most  cases  the drivers are provided as a Linux kernel
   module, such as "usbserial". However, the  device  shows  up  as  "usb-
   storage"  by  default.  usb-modeswitch solves that issue by sending the
   respective command which actually performs the switching of the  device
   from "usb-storage" to the target mode like "usbserial".

But then I read http://en.wikipedia.org/wiki/Media_Transfer_Protocol (after Googling "MTP"), which listed several Linux apps that supported MTP/PTP.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.