Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gnome-terminal works just fine when I am running Unity, but when I run Gnome shell, terminals don't work properly and have to be constantly refreshed. This is particularly annoying when using "vi" to edit text files. In the old, old days, I saw problems like this when the ".profile" file didn't have the correct setting for TERM. But I thought that modern distributions had pretty much solved this issue.

In anyone else seeing this behavior? Hard to believe that it's only me with this problem.

For what it's worth, I have this issue on every one of my four Ubuntu 11.10 installations, so I know it's not a hardware issue.

share|improve this question
    
I've been experiencing the same problem while running urxvt in gnome shell. –  Zoke Dec 21 '11 at 23:13
    
What is output of (echo $TERM), on each? –  david6 Dec 22 '11 at 0:20
1  
terminals don't work properly what do you mean by "don't work properly"? It would be more useful to include the precise symptoms of the problem, for the benefit of people that might know how to solve the problem but don't have the problem themselves, and to help other people with the same problem to find this page from search engines. –  Lie Ryan Dec 24 '11 at 15:33
add comment

3 Answers

This has been reported as a bug: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/303224

A possible fix is presented in that bug report. I can confirm that it helps in my case. The fix is to install compizconfig-settings-manager and then run ccsm. Use advanced search to change the following settings, then log out and log back in.

  • Texture filter: best
  • Lighting: checked
  • Detect refresh rate: unchecked
  • Refresh rate 200
  • Sync to vblank: unchecked
share|improve this answer
    
The problem in the bug looks related to the proprietary NVIDIA drivers. @trotter1985, can you confirm whether this is the graphics setup your desktop uses so we know for sure if you're being affected by this bug? –  WarriorIng64 Mar 6 '12 at 17:27
    
This workaround also works for me. But this settings mess Flash-Videos up. They look not good with VSync off. It also seems to my eyes that flash videos are gotten slower now :-/ –  therealmarv Mar 18 '12 at 20:26
add comment

This solved it for me: http://ubuntuforums.org/showthread.php?t=990588

share|improve this answer
    
Would you add some more information what the link infer to ? –  viyyer Jan 9 '12 at 16:49
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  WarriorIng64 Mar 6 '12 at 17:24
    
i'd vote for it. the thread provide a workaround and it works for me. it tells you to remove nvidia-current and install nvidia-173 (i also installed nvidia-173-updates). –  Dyno Fu Aug 23 '12 at 5:12
add comment

Try guake if you use terminal a lot. It's dead handy :)

share|improve this answer
    
guake as far as I know, is just a specialized use case for gnome-terminal. At least in my case it exhibited the exact same behavior. –  csgeek Jun 26 '12 at 1:34
add comment

protected by Community Mar 6 '12 at 15:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.