Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a really annoying problem! I just can't move an extension (weather indicator) from bottom panel to top panel!! I would really appreciate if someone helped!

enter image description here

share|improve this question
    
please can you link to a screenshot and add the version of ubuntu you are using to your question. –  fossfreedom Dec 21 '11 at 20:38
    
Ubuntu 11.10 with Gnome shell... failiem.lv/u/khmcgqr –  Jānis Kublinskis Dec 21 '11 at 20:41
add comment

2 Answers 2

enter image description here

The unity indicators do not display in the gnome-shell top-panel. You will need to use gnome-shell extensions such as the one in the picture.

sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell-extensions-weather

Logout and login and start gnome-tweak-tool and turn on the weather extension.

You can configure your location by finding your WOEID code from http://edg3.co.uk/snippets/weather-location-codes/

share|improve this answer
    
Gosh! Thank you very much! –  Jānis Kublinskis Dec 21 '11 at 22:39
    
Dont forget - if you are asking questions and you like the answer, click the tick button on the answer you like to accept it. Otherwise the system thinks your question remains unanswered. –  fossfreedom Dec 21 '11 at 22:42
add comment

Gnome shell treats status icons from running programs (bottom bar) differently from actual shell applets (top bar). You can get a weather extension which goes on the top bar by following this article:

http://www.webupd8.org/2011/10/install-gnome-shell-weather-extension.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.