Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, the games on Pogo.com stopped working with Sun Java in Ubuntu 10.10. I have my dad running 64bit Ubuntu 10.10 because it works fine for him and he has had no reason for an upgrade (and didnt like Unity).

He loves Pogo and plays the slots games on there regularly. Ive had Sun Java 6 installed and all worked fine until recently. I attempted an upgrade to the new Oracle Java but Pogo games still dont work.

Pogo games have historically not worked with OpenJDK and IcedTea , but I notice they (the pogo games) work GREAT (and fast) on Ubuntu 11.10 with the newest versions of OpenJDK/IcedTea.

Ive attempted to install an OpenJDK PPA for 10.10 but it does not make use of the newest versions that are available in 11.10.

I am looking for any tips on what I can do next. Any help completely appreciated!

My options I see available to me right now are:

  1. force install of newest OpenJDK somehow on 10.10
  2. try installing Firefox & Sun Java in WINE and see if Pogo games work there.
  3. upgrade his computer to 11.10
share|improve this question
    
question - why not install oracle JRE7? You will not have to find PPAs or compile OpenJDK for maverick then... askubuntu.com/questions/56104/… –  fossfreedom Dec 22 '11 at 9:53
    
Fossfreedom, thanks. Ive installed JRE7 with no luck :| The Pogo website isnt playing very nice. It doesnt recognize JRE7 and requests the user to download the latest version of Java6 instead. Looks like Im going to upgrade my dads system to 11.10 right now. I know the new Open Java works fine there. –  I Heart Ubuntu Dec 22 '11 at 18:52

2 Answers 2

I "fixed" this problem by upgrading to 11.10 on my dads computer. All works fine now with the Open Java.

share|improve this answer

You could use the openjdk PPA which has builds of OpenJDK 6 for recent versions of Ubuntu (though the last build was in January). The command line way to do this is:

sudo add-apt-repository ppa:openjdk/ppa
sudo apt-get update
sudo apt-get install openjdk-6 icedtea-web

In the Software Centre you can go to the Edit menu, choose "Software Sources", "Add ..." and put in ppa:openjdk/ppa.

share|improve this answer
    
Hamish, thanks for the reply. I have done this already. From what I can gather, openjdk-6 for maverick uses version "6b21" and in Oneiric its using "6b23". Im probably generalizing but thats what I can see just from a non technical view of openjdk. If I could force the 6b23 version I would try. I just dont know how. –  I Heart Ubuntu Dec 21 '11 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.