Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't enable lock screen mode in my laptop and also in my PC. I went to system setting > screen > lock Ctrl+Alt+L : Nothing happens! the shortcut is there but not works !

sudo apt-get --reinstall install gnome-screensaver :
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 dassault-systemes-draftsight:i386 : Depends: sendmail:i386 but it is not installable
                                     PreDepends: libdirectfb-extra:i386 (>= 1.2.7-2) but it is not going to be installed
                                     PreDepends: libxcb-render-util0:i386 (>= 0.3.6-1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
    
what happens if you run gnome-screensaver-command -l ? –  fossfreedom Dec 21 '11 at 22:10
    
nothing happens ! –  mahdiar Dec 21 '11 at 22:21
    
try sudo apt-get --reinstall install gnome-screensaver and then try again gnome-screensaver-command -l –  fossfreedom Dec 21 '11 at 22:26
    
I can't ! it says :"You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: dassault-systemes-draftsight:i386 : Depends: sendmail:i386 but it is not installable PreDepends: libdirectfb-extra:i386 (>= 1.2.7-2) but it is not going to be installed PreDepends: libxcb-render-util0:i386 (>= 0.3.6-1) but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). " –  mahdiar Dec 21 '11 at 22:31
    
ok - we are narrowing down the issue - you've got package issues. Either remove that draftsight package or try and fix it ... maybe this Q&A helps? askubuntu.com/questions/39647/how-do-i-install-draftsight-cad –  fossfreedom Dec 21 '11 at 22:43
show 2 more comments

4 Answers

I was reading around & saw that some computers if CON+ALT+L doesn't work to try the "Windows" botton + L (the button with the little Windows logo, if that's the type of computer you're using) WIN+L ---> It worked on mine, I couldn't find the shortcuts mentioned above so I tried this & it worked! Good luck!!

share|improve this answer
    
That shortcut works in Windows. Does it work in Ubuntu also? (I don't use Unity so I cannot easily test this on my Ubuntu systems.) –  Eliah Kagan Sep 3 '13 at 17:30
add comment
up vote 8 down vote accepted

I installed ubuntu tweak . go to the "Tweaks" part and then to the "Security related" . Then unchecked "Disable lock screen " ! Thats it !

share|improve this answer
1  
This is the only thing that worked for me, I had the same problem. Upvoted. Does anyone know what this actually did? –  Stavros Korokithakis Sep 19 '12 at 15:05
add comment

Try screensaver command, and see if this is the keyboard (shortcut) or the application (graphics function) that is not working:

gnome-screensaver-command -l

Also check shortcut: (should be Ctrl-Alt-L )

>> System Settings >> Keyboard >> Shortcuts >> System

  Lock screen                                  Ctrl+Alt+l
share|improve this answer
    
the fist command doesn't work and the shortcut is ok ! –  mahdiar Dec 21 '11 at 22:22
    
What error message? Command not found, etc. –  david6 Dec 21 '11 at 23:42
    
no error !! nothing happened . –  mahdiar Dec 22 '11 at 3:01
    
Try gnome-screensaver-command -a to activate. –  david6 Dec 22 '11 at 8:15
add comment

Ctrl+Alt+L

The above keyboard shortcut will lock your screen.

share|improve this answer
    
Thanks But it doesn't work ! –  mahdiar Dec 21 '11 at 22:23
    
@mahdiar but you just said in the comment on the other answer that it works. –  jrg Dec 21 '11 at 22:26
    
Sorry !!! I mean I can see the correct shortcut key in the settings but it doesn't work ! –  mahdiar Dec 21 '11 at 22:30
    
@mahdiar interesting... I think fossfreedom is on the right track in the answer above. –  jrg Dec 22 '11 at 2:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.