Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

even few days go it was working perfectly. suddenly There is no internet. I can't even reach 192.168.0.1 . I've a dual boot with window. with which I can reach to internet.

lspci says :

01:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10) 

lshw -class network says I am using r1869 driver:

*-network
   description: Ethernet interface
   product: RTL-8169 Gigabit Ethernet
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 2
   bus info: pci@0000:01:02.0
   logical name: eth0
   version: 10
   serial: 00:13:d4:07:43:2f
   size: 100MB/s
   capacity: 1GB/s
   width: 32 bits
   clock: 66MHz
   capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100MB/s
   resources: irq:17 ioport:a000(size=256) memory:d1000000-d10000ff memory:28000000-2801ffff

and that r8169 module also appears in lsmod:

r8169                  36841  0
mii                     4425  1 r8169

But there is no internet. What Can I do ?

Edit

ifconfig output:

eth0      Link encap:Ethernet  HWaddr 00:13:d4:07:43:2f  
          inet6 addr: fe80::213:d4ff:fe07:432f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:500 (500.0 B)  TX bytes:3431 (3.4 KB)
          Interrupt:17 Base address:0xe000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1200 (1.2 KB)  TX bytes:1200 (1.2 KB)

dmesg | grep eth says

[   11.955544] r8169 0000:01:02.0: eth0: RTL8110s at 0xe7f44000, 00:13:d4:07:43:2f, XID 04000000 IRQ 17
[   14.128708] r8169 0000:01:02.0: eth0: link up
[   25.024009] eth0: no IPv6 routers present
share|improve this question
    
Can you ping 127.0.0.1? The output of ifconfig might help to resolve any network errors (if it's not a hardware issue). –  lumbric Dec 21 '11 at 15:55
    
If its an hardware issue how can the windows (on dual boot) work with internet ? and yes I can ping 127.0.0.1 –  user1868 Dec 21 '11 at 16:18
    
Yeah thats true. I wanted to say a driver issue. –  lumbric Dec 21 '11 at 18:58
    
Please Check. I've attached the ifconfig output too in edit. –  user1868 Dec 22 '11 at 9:50
1  
There is no IPv4 address at eth0, is this on purpose? –  lumbric Dec 22 '11 at 12:28

1 Answer 1

This hopefully provides a solution for you and maybe also for others:

If you suspect a networking error which is probably not caused by hardware or driver problems, then this might work for you in most cases. If you have an advanced network configuration, this might not help (but then probably you know basics about networking or somebody else configured your machine, so you know better already).

  • Open the network manager: right-click on the network icon next to the clock and then "Edit connections...". Otherwise you can run nm-connection-editor after pressing ALT+F2.
  • Choose the wired (wired in your case, since it's a wired connection)
  • Add a new connection and leave everything to the default values except tick "Available to all users" and "Connect automatically" and click "Apply"
  • Edit all other entries there and unselect "Connect automatically"

Then it hopefully works (at least after the next network connect, reboot or whatever). This fixes probably any messed up network configuration. It simply sets back everything to automatically (the IP address, gateway etc. will be taken from DHCP). (There might be a lot of other or better ways, I tried to describe a very simple but also very general way)

Update Because this didn't help, some more info. I think the most common set up at home is a private network (LAN) connected to a router (often also a cable or ADSL modem) which is acting as NAT. Your private network often has the IP address 192.168.x.0 and the clients 192.168.x.y where x is some arbitrary number between 0 and 254 and y a unique number for every client. The gateway as two IP addresses, one from the network 192.168.x.0 (usually 192.168.x.1 is used) and one public IP. The clients' network configuration need to contain a unique IP address of the correct network, the correct gateway address and the correct subnet mask (usually 255.255.255.0). Then it should be possible at list to ping the router otherwise you did something wrong with these settings. Usually this configuration is automatically done with DHCP, so you don't have to care about it and just plug in the cable. Otherwise maybe your DHCP configuration is messed up or the DHCP server in the router isn't working correctly. You can always configure these things also manually. If you can ping the router but you can't ping the internet, try to ping some public IP addresses, for example 8.8.8.8. If this works but you can't ping google.com something with our DNS settings is wrong.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.