Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought this brand new lenovo B570 last week and the first thing I did was install Ubuntu 11.10 but whenI tried to connect it through a wireless connection it just didn't at all. How can this be solved? I really love Ubuntu and it would be a massive disappointment if this can be solved. Thanks!

share|improve this question
    
we need more information from you - please look at this Q&A askubuntu.com/questions/14008/… also - there is a similar question for the B575 - does the answer help with your model? askubuntu.com/questions/77675/… –  fossfreedom Dec 21 '11 at 11:03
    
Please provide some logs, i.e. /var/log/syslog, dmesg –  Andrejs Cainikovs Jan 25 '12 at 19:09
add comment

2 Answers 2

I have the same laptop (b570) and had a difficult time. Hopefully you have dual boot with windows. In my case I had to blacklist acer-wmi in the document "/etc/modprobe.d/blacklist.conf" (at the bottom type in "blacklist acer-wmi" without quotes) then reboot back into windows and turn on the wireless, reboot back into Ubuntu and it worked.

I had tried for days with just blacklisting, then messing with the hardware switch on the actual case, tried the fn key and most everything I could google with no luck. Then upon needing wireless booted into windows realized it was off there too, turned it on, back into Ubuntu 11.10 and fixed.

share|improve this answer
add comment

I found the solution from: http://ubuntuforums.org/showthread.php?t=1871781


Solution for the Issue

The following commands will enables wireless till next boot

sudo service network-manager stop
sudo rmmod acer_wmi
sudo modprobe acer_wmi
sudo rfkill unblock all
sudo service network-manager start

After this step the status message in the Network Manager will be “Wireless is disabled”. Now Enable wireless from the Network Manager using the following commands

sudo rmmod -f acer_wmi

Wireless networks will be detected and connected. To make this change permanent use

sudo su
echo "blacklist acer_wmi" >> /etc/modprobe.d/blacklist.conf
exit

Now if everything goes well you will have Wireless enabled on your Thinkpad. Thanks to David John for sending us the solution

and here's the link http://www.zyxware.com/articles/1694/wireless-disabled-by-hardware-switch-issue-on-the-thinkpad-z570-in-ubuntu-solution

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.