Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have dual monitor set up in Ubuntu 11.10. I want to have a single wallpaper spanned across both monitors. How do I do this?

share|improve this question
Might want to note, although nitrogen doesn't appear to change the wallpaper of nvidia machines, it has a cool side effect that still might make it worthwhile. If the changes via nitrogen occur more recently than your changes in the default ubuntu desktop manager, the images will show up in the background of terminals, if their background is set to transparent. So you essentially have a 'hidden' wallpaper. – user136518 Feb 28 '13 at 20:40
up vote 14 down vote accepted

First you need a wallpaper large enough for both monitors. You can either make one with the gimp or down load one. Alternately you can use a separate image for each monitor.

You can then install a handy little application, nitrogen

sudo apt-get install nitrogen

You then run nitrogen with the path to the directory with your picture(s)

nitrogen ~/Pictures

And select the image. At the bottom of nitrogen, select "automatic" and "Full screen" as options. alternately you can use nitrogen to set a separate image on each screen, up to you (sort of depends on your background images).


share|improve this answer
Yep. I got it downloaded and running. However when I press 'Apply' nothing happens. I've got a Nvidia graphics card installed which means use of the Nvidia X Server settings. – MegaBubbletea Dec 21 '11 at 8:30
Odd, nitrogen works with my nvidia card. – bodhi.zazen Dec 21 '11 at 13:14
Restarted PC yet still not working. Even tried using root access. No luck either. – MegaBubbletea Dec 23 '11 at 7:54
Nitrogen works after this tweak: – zengr Nov 27 '12 at 18:17

if using gnome-shell, in tweak tool under desktop there is an option to have the image span the desktop. This makes it go across both monitors(or all).

No Nitrogen Necessary

Unity also has this same option as shown below:

Appearance options - span

share|improve this answer
+1 This is by far the simplest answer. For two 1080p monitors just crop an image to 3840x1080, select it, then choose 'span' in the options. – Tom Brossman Mar 18 '14 at 9:39
+1 Best answer in 2014!! – wim Jun 6 '14 at 11:22
The options have changed since the original question. In 2011 , at the time of the question, there was no option to "Span". – bodhi.zazen Jun 6 '14 at 21:48

Nitrogen answer works, but another tweak is necessary. Run Advanced Settings in Gnome Tweak Tool, go to Desktop section and switch Have file manager handle the desktop off. Then wallpapers set via Nitrogen will be displayed.

If you do not have the Gnome Tweak Tool, you can use this command instead. It's an easier solution, too:

gsettings set org.gnome.desktop.background show-desktop-icons false

However there is strong disadvantage. All icons disappear from the desktop and the context menu can't be invoked. Unless you need icons on desktop this solution may be useful for you.

share|improve this answer
Thankyou for your answer. Although that is a good solution I still want my desktop icons. I hope Ubuntu will fully support multiple monitor wallpapers better in future releases. – MegaBubbletea Jan 27 '12 at 6:45
As @topr mentioned, Nitrogen will not give you the option of desktop icons and context menus. A much better option is to combine your images in a single file, and use "span over multiple monitors" option. You ca combine images with ImageMagick, using convert +append -gravity south wallpaper*.jpg combined_wallpaper.jpg – Gui Ambros May 24 '14 at 18:55

I do not appear to be able to add a comment to an answer due to my low rep (lolz), so this is meant to be on @topr's answer.

I am the author of Nitrogen and there is code in there to detect a gnome desktop and set it properly so that you don't need to make this change, but it appears to not be functioning on modern Ubuntus. I will investigate.


share|improve this answer
using the gnome-tweak-tool solved this issue... see here:… – m13r Jun 18 '15 at 13:26

Take a look at this link:

you can use shotwell to resize te image as your combined monotors resolution then set it as background using the default image viewer of ubuntu.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.