Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a clean Kubuntu 11.10 64bit on a Dell Latitude E6500. Rebooted after install, ran the update manager Muon first thing, said apply all upgrades, and then at 57% ("Running dpkg") the progress bar freezes and that's it.

No external drive attached, plenty of space on the hard drive, and this is the third clean install attempt. (On that same computer, Ubuntu 11.10 and Mint 11 worked just fine). Any ideas?

share|improve this question
    
hard to tell without additional information. Can you close Munon and try from the command line ? sudo apt-get update ; sudo apt-get install -f –  bodhi.zazen Dec 21 '11 at 5:47
    
dpkg was crashing on my system last month. I did nothing, and the problem went away as the packages changed –  marinara Dec 21 '11 at 15:17
add comment

3 Answers 3

I had the same problem. I opened a terminal window and did the following:

ps -e | grep muon

This identified the process. Then (number identifed above):

sudo kill ####

I then rebooted. After which:

sudo dpkg --configure -a

I then did:

sudo apt-get update
sudo apt-get install -f

now everything is fine.

share|improve this answer
add comment

Just to add, I believe what you saw was reported on this bug: https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/855793 .

In the near-future, I would recomend using synaptic/apt-get/aptitude for doing upgrades.

share|improve this answer
add comment

I tried the sudo dpkg --configure -a approach listed above and it did not help. I have also tried it on a virtual machine which wont even run after the update. However, I have found another approach which did work at least on Vmware (haven't tested on a real machine yet)

From a fresh install of Kubuntu 11.10 with no updates.

Open a terminal (using Ctrl+Alt+T to save some time) and install aptitude.

sudo apt-get install aptitude
sudo aptitude update
sudo aptitude safe-upgrade

It takes a long time to update but it doesn't hang during the process.

I also tried the whole thing with synaptic and it also ran fine afterwords.

One thing to note is that after using either approach the Software Center aka muon-installer will no longer run due to some file ownership issues.

share|improve this answer
add comment

protected by Community Mar 4 '12 at 16:40

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.