Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 11.04 to 11.10. After the upgrade, I can no longer adjust the screen brightness or the volume using keyboard (before the upgrade, using Fn+F4, Fn+F11, etc. worked).

Using Fn+F2 to disable wireless still works, so I guess the Fn key itself is being recognised.

I tried to follow the instructions here, but I don't have a file in /etc/X11 called xorg.conf.

I also tried following this workaround, but it had no noticeable effect.

I've also tried going to SettingsKeyboardShortcuts and reassigning the brightness and volume controls, both to the default keys and to new combinations. These changes don't have an effect even after rebooting.

Googling has found bug reports where pressing the media keys brings up a "no entry sign" rather than changing the volume. When I press the keys there's no response at all.

I've also seen various people say a workaround is to have totem running in the background; this doesn't work for me either.

Finally, I tried installing keytouch; I was able to install keytouch-editor but got the message "Unable to locate package keytouch".

Any more ideas? I'd be very grateful if anyone could help me (even by pointing to a thread I've missed)!

share|improve this question
    
Wow, this is an old question... still need an answer? If you don't have an xorg.conf file, you can actually just make one to follow those instructions. –  Chan-Ho Suh Apr 15 '12 at 9:58
    
Still looking for an answer -- thanks for your response. I tried creating an xorg.conf file and following the instructions, but it didn't help. –  Adina G Apr 15 '12 at 14:41
    
Are you using the default graphics driver or a proprietary one like nvidia? –  Chan-Ho Suh Apr 16 '12 at 0:34
    
The default one, I think (how would I check?). –  Adina G Apr 16 '12 at 2:54
    
in the terminal, type lspci -v Last few lines will look like: Kernel driver in use: nvidia Kernel modules: nvidia_current, nouveau, nvidiafb –  Chan-Ho Suh Apr 16 '12 at 2:59
show 6 more comments

1 Answer 1

up vote 1 down vote accepted

I discovered that running gnome-settings-daemon fixes this issue (and gives me a functional battery status indicator again), so I added it to my startup commands.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.