Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.04 on Virtualbox. Everything worked fine until I had to install a wirelsss network card to my stationary (network cabel outside house was damaged - so borrowing neighbour network).

Now I only get Network disabled.

My nettwork file looks like this:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0

#NetworkManage
#iface eth0 inet dhcp

I've tried "enabling" iface eth0 inet dhcp, but that only made restarting the network hang.

I've tried creating a new Wired connection, but that didn't help either.

running ifconfig gives me this info:

eth0      Link encap:Ethernet  HWaddr 08:00:27:eb:ac:42  
          inet6 addr: fe80::a00:27ff:feeb:ac42/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host

Any help much appreciated!

update

user@ubuntu:~$ iwconfig lo no wireless extensions.

eth0 no wireless extensions.

share|improve this question
    
You're running Ubuntu within VirtualBox? Have you changed the VM settings to use the new network device? –  Oli Dec 21 '11 at 0:33
    
@Oli, I'm running Ubuntu within Virtualbox. –  Steven Dec 21 '11 at 0:41
    
@bodhi.zazen, since I'm running Ubuntu as a virtual server using Virtualbox, I should only need to run eth0 and have a bridge between Ubuntu and Win7. –  Steven Dec 21 '11 at 0:42
    
If you properly configured virtualbox to use your wireless card, then try sudo dhclient eth0 –  bodhi.zazen Dec 21 '11 at 0:57
add comment

1 Answer

up vote 2 down vote accepted

The guest-Ubuntu configuration shouldn't need to change. At all. A guest OS is given a virtual network connection based on what the host machine makes available.

The only changes that need to happen are to the VM settings so it knows to bridge to your wireless connection instead of the previously wired connection.

  1. Shut down the guest
  2. Load the Virtualbox Manager (if it's not already running)
  3. Right click your Ubuntu VM and click Settings
  4. Under Network, assuming you're bridging, change the Name of the network device to that of your wireless device.
  5. Click Ok, run your VM and relax.

If you're not bridging - you probably aught to be.


Failing that a longer workaround would be to ditch the wireless dongle and get a router near the computer and set that up as a repeater/bridge and plug your computer into that. Nature always finds a way.

share|improve this answer
    
@oil, I tested. Swithing from Bridge -> NAT, enables the network, but then I'm nto able to work on my projects. Setting it back to Bridged disables the network again. –  Steven Dec 21 '11 at 1:11
    
I've tried using the bridge function on my wireless - but that only works when the WAN cable it pluggged in. –  Steven Dec 21 '11 at 1:13
    
In that case consider adding a new connection to the VM. One NATted for Internet, one bridged for local networking. –  Oli Dec 21 '11 at 1:17
    
Solved it :) Up til now, I had right clicked my VM and gone to settings -> Network. What I did now, was to go from main menu in VirtualBox: Machine->settings->network. It was set to NAT. Setting this to bridge, sovled it. Thanks for your help :) –  Steven Dec 21 '11 at 1:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.