Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Gnome3/Gnome Shell/Ubuntu 11.10. Today, when I began using my machine, it would not co-operate with me. Trying to type simple documents, my SHIFT-p was captured -- and spawned an xterm window!

I have no idea how I may have caused this anomaly. But I searched the various locations trying to find the culprit...

I checked the "Shortcuts" tab of the "System Settings|Hardware|Keyboard" applet... no assignment to SHIFT-p in any of these lists...

I checked the Commands panel in "CompizConfig Settings Manager" (from Gnome Menu|Other)... no assignment there either.

After reading some other related keymapping issues asked in askubuntu, I brought up the xev application to see what it would report... while programmatically pressing each key on the keyboard, examining the report from xev, I learned that SHIFT-w-w is also mapped to bring up an xterm!

while exploring, it appears (using ps -ef), that both commands are mapped to "sh -c xterm"...

How can I fix this? I don't know where to turn next.

ps -ef

reports three processes being initiated each time I press SHIFT-p (or SHIFT-w-w):

* sh -c xterm
* xterm
* bash

Can anyone help me to troubleshoot this problem?

UPDATE

The problem boiled down to an issue with my .xbindkeysrc.scm file. I had explored a tutorial on the topic some weeks back and had downloaded a tutorial (.xbindkeysrc.scm) file. After playing with the tutorial for a little while, I disabled the file.

When doing some housekeeping on my system this morning, I inadvertently re-enabled the file. This caused the mysterious behavior.

share|improve this question
    
So, I went to a console and tried to reproduce the problem. But failed. This led me to realize that it was specific to the X environment. After digging around, I realized it was due to settings in my .xbindkeysrc.scm file! –  TheGeeko61 Dec 21 '11 at 2:05
    
So this can be deleted... (But I'm not sure how to do that.) –  TheGeeko61 Dec 21 '11 at 2:07
add comment

1 Answer 1

up vote 1 down vote accepted

The problem boiled down to an issue with my .xbindkeysrc.scm file. I had explored a tutorial on the topic some weeks back and had downloaded a tutorial (.xbindkeysrc.scm) file. After playing with the tutorial for a little while, I disabled the file.

When doing some housekeeping on my system this morning, I inadvertently re-enabled the file. This caused the mysterious behavior.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.