Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10. In System Settings -> Network I can add a Socks proxy but it doesn't work with my UDP application or even Firefox (it just connects using my real IP). What do I need to do to send my UDP program's data through a proxy ?

share|improve this question
    
What UDP application (DNS with TOR ?) and what proxy and what do you mean "Firefox (it just connects using my real IP)" ? From your post I suspect you are trying to use TOR. –  bodhi.zazen Dec 20 '11 at 23:52

1 Answer 1

  1. 'System Settings -> Network' doesn't enforce a proxy. It merely recommends applications to use a proxy. (System Settings are Gnome settings and Gnome apps (and some others) use them. I believe, Firefox should also default to using Gnome settings, but I may be mistaken.)
  2. The only way to enforce using a proxy, is a firewall that blocks all other traffic.
  3. While SOCKSv5 supports UDP, SOCKS is more commonly used for TCP.
  4. If you want a particular application to use a proxy, this application must support proxies.
  5. If you want to tunnel all traffic (hide your real IP), consider using a VPN instead.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.