Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed ubuntu 11.10 on my new Dell and I've had troubles starting. After adding acpi=off to the boot options it at least boots now.

Right now I'm struggling with NVIDIA Optimus. Because I messed my last install up, I completely reinstalled Ubuntu and did the following:

  1. Downloaded NVIDIA driver (525m) from NVIDIA website & installed it
  2. Installed ironhide and configured it
  3. Rebooted

Now unity3d isn't working anymore (it worked before the NVIDIA driver) and I can't run optirun because of the missing acpi (that's the error: cat: /sys/class/power_supply/*/online: No such file or directory)

So I'm really stuck right now and I don't really know where the problem is.

share|improve this question

3 Answers 3

So I've just figured out how to do it. I made a wordpress blog and wrote how I did it. Hope it's gonna help somebody.

http://goof848.wordpress.com/2011/12/20/how-to-setup-ubuntu-11-10-on-a-inspiron-17r-n7110/

share|improve this answer

Never ever download and install the driver from nvidia.com unless you know how to fix it with nVidia Optimus laptops. The driver can be installed from the Ubuntu repositories, package nvidia-current but that will not work for Optimus laptops.

Unity3D is broken because the nvidia driver assumes that it's loaded with the graphical server which is not the case because Optimus is not supported out-of-the-box.

See How well do laptops with Nvidia Optimus work? for workarounds and a more detailled explanation.

share|improve this answer

Optimus is a hybrid graphics technology. It has both Intel and Nvidia graphics. Problem is that Ubuntu by default lacks functionality for disabling the Intel hardware and letting the system "be" Nvidia. So if you install the Nvidia driver, that disables the Intel 3D functionality; it comes up as an Intel system but with the (invalid) Nvidia 3D driver, soooo no 3D.

Some hybrid systems allow you to toggle the graphics device in BIOS. If you are able to do that, you're in luck. Just toggle off the Intel graphics and install -nvidia. Otherwise, you're screwed and need to stick with just the -intel driver. Uninstall (and purge if needed) the proprietary -nvidia driver, to restore 3D functionality.

There are some 3rd party workarounds such as Bumblebee, which enable you to more easily toggle between the two options. However these are not officially supported in Ubuntu so you'll be a bit on your own if you want to go this route.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.