Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Clean install of 11.10. Tried Unity and really struggled and have switched to Gnome-shell. I have set up Skype as a startup application. It starts up properly, but not sure what to do without without keeping it fully open. If I close it, the application completely closes. In 10.10 I was able to close it, and it appeared in the top panel notification area.

I have installed the gnome-shell-classic-systray extension. Also SkypeNotificationExtension but these appear to do nothing.

If I close Skype, Skype will still run but there is no way to get to it interface wise. If I kill all instances, then restart Skype manually. It does appear in the panel properly.

I suppose this maybe a timing issue, but I don't know how to automatically delay Skype until everything else completes.

share|improve this question
    
Gnome Shell doesn't use Indicators by default, Skype uses the Indicator area to minimize not the Notification area. –  Uri Herrera Dec 20 '11 at 20:10

1 Answer 1

up vote 4 down vote accepted

If you select in Skype Options to minimise on startup, it should appear in the system-tray area - this is bottom-right of the screen.

enter image description here

Move your mouse to the bottom-right to reveal this area. Likewise clicking the "X" of the skype window will minimise the application to this area.

If you are having timing issues on startup, you can introduce a delay for a Startup-Application by using a command syntax:

bash -c "sleep 10 && skype"

This will sleep for 10 seconds before starting skype.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.