Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 (64 bits) and I do not want to mount automatically USB thumb drives in my system. I tried the command dconf-editor and gconf-editor but there isn't the icon to disable it in nautilus preferences (apps|nautilus|preferences|media_automount).

Thanks.

share|improve this question

3 Answers 3

Install dconf-tools, and run dconf-editor. Then see in dconf-editor, key

org.gnome.desktop.media-handling/automount
share|improve this answer
1  
If you don't already have dconf-editor installed you can find it in the Software Center. –  Tom Brossman Dec 20 '11 at 16:48

I believe you can find dconf-editor is part of 'dconf tools'. If you search for dconf, it should show up.

The key is under 'org', as posted, dig down to .... org.gnome.desktop.media-handling/automount

share|improve this answer

You first need to install dconf editor in Software Center. In my case it shows remove because I have already installed it

enter image description here

Then you need to open dconf editor via Dash

enter image description here

Then goto org.gnome.desktop.media-handling

You will find automount checkbox on right hand side. Uncheck it

enter image description here


If you prefer not to install anything extra in your system. You can use gsettings to change dconf keys.

To disable Nautilus automount use this command in a terminal

gsettings set org.gnome.desktop.media-handling automount false

To enable it again open a terminal and use this command

gsettings set org.gnome.desktop.media-handling automount true
share|improve this answer
2  
I have "defaced" you answer with terminal instructions just in case a user does not want to install dconf-tools in his system, hope that is OK with you. –  Bruno Pereira Feb 9 '12 at 9:43
    
@BrunoPereira LOL! @ "Defaced". I always believe in providing graphical instructions –  Manish Sinha Feb 9 '12 at 13:19
    
Agreed, nothing wrong there, its just an extra that did not deserve to be all by it self ;) –  Bruno Pereira Feb 9 '12 at 14:34
    
useful instruction :) –  BlueBird Sep 2 at 5:40
    
@ManishSinha Where can I find the setting in Ubuntu 14.04.? –  JJD Nov 27 at 12:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.