Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am creating a preseeding file for an automatic ubuntu 11.10 installation and I am having problems setting up the keyboard configuration. I need the keyboard to be configured as abnt2 so I added this to the file:

# Keyboard selection.
# Disable automatic (interactive) keymap detection.
d-i console-setup/ask_detect boolean false
d-i keyboard-configuration/layoutcode string br
d-i keyboard-configuration/modelcode abnt2 

But the keyboard is set as us. And the first time I log into the new installation I get an "incomplete language support error".

What is the correct way of setting up an abnt2 keyboard layout?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

AFAIK you need all of

d-i     keyboard-configuration/variant select English (US)
d-i     console-keymaps-at/keymap select us
d-i     keyboard-configuration/xkb-keymap select us

and possibly

console-setup/ask_detect=false console-setup/layoutcode=us keyboard-configuration/xkb-keymap=us

on your append line of txt.cfg (or whatever isolinux config)

share|improve this answer
add comment

Maybe the correcting setting is:

d-i     console-setup/model               select Brazilian ABNT2
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.