Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to install Xubuntu on my current Ubuntu installation, it won't let me install "xubuntu-desktop", but it will instead recommend me to install other packages in the Xubuntu repos.

Has the package name changed or do I have to wait for an updated version?

share|improve this question
UPDATE: I figured it out. I installed an unstable repo for GIMP and I had to force install it in order to get the package list working again. Problem solved. Installing xubuntu-desktop now. – Robert Dec 20 '11 at 9:33
You could put what you did to fix it as an answer and accept it :) – Nitin Venkatesh Dec 20 '11 at 12:48

The xubuntu-desktop is a meta-package. That means, that it's a package that serves as a single point linking to other packages. Something like a pointer to many other different packages.

Hence xubuntu-desktop package's only contents are links to other xfce related packages, the packages that make up the Xubuntu Desktop.

You could also read the Ubuntu Community Documentation on MetaPackages

share|improve this answer
But I installed the xubuntu-desktop with the command: sudo apt-get install xubuntu-desktop. Explain that! – Alvar Dec 20 '11 at 8:52
Same, I was able to do sudo apt-get install xubuntu-desktop before, but now I'm starting to think my package manager is broken. – Robert Dec 20 '11 at 8:58
@Alvar: Yup that is the command to install xubuntu-desktop which in turn installs all the other required packages to make your xfce DE. @Robert:Tried sudo apt-get update && sudo apt-get install xubuntu-desktop ? – Nitin Venkatesh Dec 20 '11 at 9:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.