Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am new to linux and i am using ubuntu(11.01) and through google i installed php5.3, mysql apache2 and phpmyadmin each were working smooth, but i needed php4.4.9

i google and download the php4.4.9 and with following steps : http://www.websoftix.com/Blog/How-To-run-php4-in-paralel-with-php5-on-Ubuntu-11

and now php4 is working but when i am going to start phpmyadmin i got message :

PHP 5.2+ is required

it means the phpmyadmin not working for php4.4.9 but now i don't know what to do, means how and from where i installed phpmyadmin for php4.4.9 Please help me to solve out this problem.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

You shouldn't use php4. It's not supported anymore, so no security updates will be provided. Not a good thing on a public web server.

Anyway the instruction you linked say "php4 in parallel with php5". So you should be able to configure a second virtual host for apache running php5 for phpmysql.

share|improve this answer
    
you are right, but what i did. i tried to see some old version of ubuntu, which has php4, with all the stuffs. If you know then plz tell me, cause i don't have the depth knowledge of linux, but i want that's why i am here,, Plz provide me some alternate solution if anyone have.. –  jogesh_pi Dec 27 '11 at 5:00
    
I don't understand the need for php4. But I provided a solution in the 2nd paragraph. You still have php5 if you followed the instructions you linked. You can run phpmyadmin at the same time at php5 and something else with php4. Maybe you just have to open http://localhost/phpmyadmin –  lumbric Dec 27 '11 at 10:14
    
but when i am tring to restart apache then i got something different errors ` * Restarting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName [Tue Dec 27 16:28:59 2011] [warn] VirtualHost 127.0.0.1:0 overlaps with VirtualHost 127.0.0.1:0, the first has precedence, perhaps you need a NameVirtualHost directive` –  jogesh_pi Dec 27 '11 at 11:00
    
its working but apache not restarting.. –  jogesh_pi Dec 27 '11 at 11:13
add comment

You need to install an older version of PhpMyAdmin. I think you will have to go all the way back to PhpMyAdmin 2.1x to find one compatible with PHP 4.49. If you go to the downloads section of the PhpMyAdmin site there is a link to a SourceForge page that contains the older versions. Check the requirements to be sure, but I believe everything beginning with version 3.0 requires PHP 5x.

share|improve this answer
    
i did it, first i removed the phpmyadmin and tried to install with 'apt-get install phpmyadmin 2.1X' but this command skip the old version and took the latest version by default, and sorry for the sourceforge link but i don't know about the manually installation if you have some link to do that step by step then plz provide me.. –  jogesh_pi Dec 27 '11 at 4:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.