Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried several things like mentioned in the forums, but I'm at a loss. Everything works fine except wireless Internet. I see using Terminal that it detects the drive but it is disabled. I go to enable it, and it quickly puts the check mark on, then checkmark comes off. No error messages. I tried checking for updates, installing a Windows based wireless driver and happend on Ubuntu version 10, 11.04 and 11.10 now. Same issue. I really want to switch over to using Ubuntu, but if I can't get a basic thing like wireless Internet, I can't begin to try various programs, etc. My laptop is only a few months old and came with Windows 7 if that helps.

share|improve this question
up vote 1 down vote accepted

heh, you should disable acer_vmi module, it's quite common, this thread should fix this:

Wireless doesn't work on a Lenovo V570

in short, add the following line in /etc/modprobe.d/blacklist.conf

blacklist acer-wmi
share|improve this answer
Thanks so much! This worked like a charm. You're a rock star! Now I can use wireless when I'm not at work and really start learning more about Ubuntu. – Daniel Gauthier Dec 20 '11 at 17:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.