Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install mint-meta-mate which is Gnome 2 fork on 11.10 - 32bit

with aptitude i get this:

    The following NEW packages will be installed:
      caja{a} cowsay{a} fortune-mod{a} fortunes-husse{a} fortunes-min{a} 
      gir1.2-mate-menus{a} gtk2-engines-aurora{a} gtk2-engines-candido{a} 
      intltool{a} libart-2.0-dev{a} libcaja-extension{a} libgail-dev{a} 
      libmate{a} libmatecanvas{a} libmatecomponent{a} libmatecomponentui{a} 
      libmatedesktop{a} libmatekbd{a} libmatekeyring{a} libmatenotify{a} 
      libmatepanelapplet{a} libmateui{a} libmateweather{a} librecode0{a} 
      libtasn1-3-bin{a} libtasn1-3-dev{a} mate-backgrounds{a} mate-common{a} 
      mate-conf{a} mate-conf-common{a} mate-conf-editor{a} 
      mate-control-center{a} mate-corba{a} mate-desktop{a} mate-dialogs{a} 
      mate-doc-utils{a} mate-file-manager{a} mate-icon-theme{a} mate-keyring{a} 
      mate-media{a} mate-menus{a} mate-mime-data{a} mate-notification-daemon{a} 
      mate-panel{a} mate-panel-common{a} mate-polkit{a} mate-session-manager{a} 
      mate-settings-daemon{a} mate-terminal{a} mate-utils{a} mate-vfs{a} 
      mate-window-manager{a} mint-artwork-common{a} mint-artwork-gnome{a} 
      mint-artwork-mate{a} mint-backgrounds-lisa{a} mint-common{a} 
      mint-info-fluxbox{a} mint-meta-mate mint-translations{a} mint-x-icons{a} 
      mint-x-theme{a} mint-z-theme{a} mintdesktop{a} mintmenu{a} mintsystem{a} 
      python-corba{a} python-mate{a} python-mate-desktop{a} python-mate-menu{a} 
    The following packages will be upgraded:
      libgail-common libgail18 libgtk2.0-0 libgtk2.0-dev 
    4 packages upgraded, 70 newly installed, 0 to remove and 34 not upgraded.
    Need to get 114 MB of archives. After unpacking 315 MB will be used.
    The following packages have unmet dependencies:
      gtk2-engines-pixbuf: Depends: libgtk2.0-0 (= 2.24.6-0ubuntu5) but 2.24.6-0ubuntu5linuxmint1 is to be installed.
    The following actions will resolve these dependencies:

         Remove the following packages:                       
    1)     gnome-themes                                       
    2)     gnome-themes-selected                              
    3)     gnome-themes-ubuntu                                
    4)     gtk2-engines-pixbuf                                
    5)     openshot                                           
    6)     ubuntustudio-video                                 

         Keep the following packages at their current version:
    7)     mint-artwork-gnome [Not Installed]                 
    8)     mint-artwork-mate [Not Installed]                  
    9)     mint-meta-mate [Not Installed]                     



    Accept this solution? [Y/n/q/?] 

With apt-get this:

The following extra packages will be installed:
  caja cowsay fortune-mod fortunes-husse fortunes-min gir1.2-mate-menus
  gtk2-engines-aurora gtk2-engines-candido gtk2-engines-pixbuf intltool
  libart-2.0-dev libcaja-extension libgail-common libgail-dev libgail18
  libgtk2.0-0 libgtk2.0-dev libmate libmatecanvas libmatecomponent
  libmatecomponentui libmatedesktop libmatekbd libmatekeyring libmatenotify
  libmatepanelapplet libmateui libmateweather librecode0 libtasn1-3-bin
  libtasn1-3-dev mate-backgrounds mate-common mate-conf mate-conf-common
  mate-conf-editor mate-control-center mate-corba mate-desktop mate-dialogs
  mate-doc-utils mate-file-manager mate-icon-theme mate-keyring mate-media
  mate-menus mate-mime-data mate-notification-daemon mate-panel
  mate-panel-common mate-polkit mate-session-manager mate-settings-daemon
  mate-terminal mate-utils mate-vfs mate-window-manager mint-artwork-common
  mint-artwork-gnome mint-artwork-mate mint-backgrounds-lisa mint-common
  mint-info-fluxbox mint-translations mint-x-icons mint-x-theme mint-z-theme
  mintdesktop mintmenu mintsystem python-corba python-mate python-mate-desktop
  python-mate-menu
Suggested packages:
  filters fortunes libgail-doc libgtk2.0-doc mate-doc-utils-gnome
The following NEW packages will be installed:
  caja cowsay fortune-mod fortunes-husse fortunes-min gir1.2-mate-menus
  gtk2-engines-aurora gtk2-engines-candido intltool libart-2.0-dev
  libcaja-extension libgail-dev libmate libmatecanvas libmatecomponent
  libmatecomponentui libmatedesktop libmatekbd libmatekeyring libmatenotify
  libmatepanelapplet libmateui libmateweather librecode0 libtasn1-3-bin
  libtasn1-3-dev mate-backgrounds mate-common mate-conf mate-conf-common
  mate-conf-editor mate-control-center mate-corba mate-desktop mate-dialogs
  mate-doc-utils mate-file-manager mate-icon-theme mate-keyring mate-media
  mate-menus mate-mime-data mate-notification-daemon mate-panel
  mate-panel-common mate-polkit mate-session-manager mate-settings-daemon
  mate-terminal mate-utils mate-vfs mate-window-manager mint-artwork-common
  mint-artwork-gnome mint-artwork-mate mint-backgrounds-lisa mint-common
  mint-info-fluxbox mint-meta-mate mint-translations mint-x-icons mint-x-theme
  mint-z-theme mintdesktop mintmenu mintsystem python-corba python-mate
  python-mate-desktop python-mate-menu
The following packages will be upgraded:
  gtk2-engines-pixbuf libgail-common libgail18 libgtk2.0-0 libgtk2.0-dev
5 upgraded, 70 newly installed, 0 to remove and 33 not upgraded.
Need to get 115 MB of archives.
After this operation, 315 MB of additional disk space will be used.
Do you want to continue [Y/n]? 

Why does aptitude wants to remove some packages like openshot? It doesn't make sense to me.

share|improve this question
    
Can you specify the exact commands you issued? –  enzotib Dec 19 '11 at 11:33
    
yes sudo aptitude install mint-meta-mate sudo apt-get install mint-meta-mate –  user1079002 Dec 19 '11 at 11:48
    
I suggest to first perform a apt-get dist-upgrade or a aptitude full-upgrade before installing. –  enzotib Dec 19 '11 at 11:49

2 Answers 2

Neither aptitude nor apt-get want to remove any packages:

4 packages upgraded, 70 newly installed, 0 to remove and 34 not upgraded.

and

5 upgraded, 70 newly installed, 0 to remove and 33 not upgraded.

apt-get seems to have one more update in tree. However, you are warned that there are some unmet dependencies in your system which might require your attention.

To repair dependencies read carefully the outputs of

sudo apt-get -f install

Then apt will show you a solution as well. You should see whether you need the packages and reinstall any broken dependencies if needed, or remove them or reinstall, which will also install the packages they depend on.

share|improve this answer
    
well, I wish I was paying attention when similar situation occured to me last week. I was installing php-gtk and somewhere in the process while installing needed packages aptitude suggested upgrading php5 and put them belowe just like this: Remove the following packages, and I thought it will upgrade them but it didn't. It removed the whole php5 and some other stuff and I needed to install them again. –  user1079002 Dec 19 '11 at 11:52
    
Usually broken dependencies arise when you try installing a package which is just not made for your system. Usually the consequence is, that apt just tries to remove this package. –  Michael K Dec 19 '11 at 12:02

The reason for the conflict is prefectly clear in the output

The following packages have unmet dependencies:
      gtk2-engines-pixbuf: Depends: libgtk2.0-0 (= 2.24.6-0ubuntu5) but 2.24.6-0ubuntu5linuxmint1 is to be installed

If you say no a few times to aptitude, it should eventually figure out the solution that doesn't involve removals. After all, apt-get did.

share|improve this answer
    
yes, but sometimes doesn't. And the last time when I was trying to install php5-mysql aptitude always wanted to remove php5-cli and php5-cgi, and apt-get didn't want to install. I had to go with aptitude and later install removed packages –  user1079002 Jan 11 '12 at 16:05
    
Yeah, I think these days apt-get's resolver is better. I still prefer having the ability to guide aptitude interactively, though. –  tumbleweed Jan 11 '12 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.