Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have several tens of thousands of bookmarks in Firefox. Whenever I accidentaly hover over the "Bookmarks" entry of Firefox menu in global menu, my whole desktop freezes for half a minute.

Now, I know the obvious solution is "less bookmarks". But that is a workaround. I actually consider this a bug, because when an app cannot handle X amount of Things, it should disallow a user to have more then X things :).

But for now, is there a quickfix?

share|improve this question
1  
You could organize your bookmarks in folders and subfolders. –  enzotib Dec 19 '11 at 9:58
    
I was afraid that would be the answer. Pity, because that requires me to write some parsers for when I export/sync the bookmarks from my online bookmarking tool. –  berkes Dec 23 '11 at 10:40
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 8 '12 at 4:08
add comment

closed as off topic by Marco Ceppi Feb 8 '12 at 12:26

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Optimize places.sqlite database. You can do that with BleachBit, an extension or a sqlite3 script.

If that doesn't help, export your bookmarks to a html file using the Import and Backup menu of the Bookmarks Manager (CTRL+SHIFT+O). Then close Firefox, open your profile folder under ~/.mozilla/firefox/xxxx.default/ or something like that, then rename the file places.sqlite to places.sqlite.bak. Open Firefox, import your bookmarks from the html file using the Import and Backup menu.

share|improve this answer
    
Optimizing helps a little. But does not solve the problem. –  berkes Dec 23 '11 at 10:40
    
I have added another option to my reply. –  lovinglinux Dec 23 '11 at 23:34
    
Thanks for all the help. The problem is not that sqlite does not perform well enough or that my database is dirty. The problem is that loading >10.000 bookmarks takes too long; no matter how well my (SSD) system performs nor how clean the database is. –  berkes Dec 25 '11 at 11:04
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.