Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some trouble mounting shares on 11.10. I've installed pyNeighborhood through which I can mount windows shares as root. I want to be able to mount them as non-root so that I can write to the shares. I did some googling and tried a few things, but none of it helped:

sudo chmod 6755 /sbin/mount.cifs
sudo chmod 6755 /bin/umount
sudo chmod u+s /sbin/mount.cifs
sudo chmod u+s /bin/umount

Any ideas?

Mounting gives this error:

mount.cifs: permission denied: no match for /home/myUser/pyNeighborhood/WORKGROUP/myServer/myShare found in /etc/fstab
share|improve this question

closed as too localized by Bruno Pereira Mar 18 '12 at 0:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What exactly doesn't work, what error does mount.cifs give? –  jelmer Dec 19 '11 at 15:04
    
mount.cifs: permission denied: no match for /home/myUser/pyNeighborhood/WORKGROUP/myServer/myShare found in /etc/fstab –  theAngler Dec 19 '11 at 23:49
    
This question appears to be abandoned as there hasn't been any activity for a longer period of time. I'm voting to close it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it reopened. Thanks! –  htorque Feb 25 '12 at 21:42
    
This is a security restriction in recent versions of Samba. See bugs.launchpad.net/ubuntu/+source/cifs-utils/+bug/657900 –  tripleee Mar 25 '13 at 10:29

1 Answer 1

If the USER has to mount it, you can always use GVFS. Its the same as clicking, Places > Network > Server > Path and seeing that pretty icon in the Places folder, and your desktop.

Term: gvfs-mount smb://serverip/path

This will add it to the places menu, and allow you to unmount it without using root.

Drawbacks:

  • Shares goto ~/.gvfs by default, you can always map them to another area if needed. If you are a click based person this wont matter to you.
  • If there is a password on the share, there is no way to auto mount it. Must be done manually.

If these are fixed shares you create at the boot process, you can use fstab and CIFS.

Add a line like this to your fstab file.

Open Share:

//serverip/path /mnt/path cifs dir_mode=0775,guid=1000 0 0

Passworded share:

//serverip/path /mnt/path cifs credentials=/root/.smbpass,dir_mode=0775,guid=1000 0 0

For a passworded share, create a file /root/.smbpass Add lines like this to it...

username=<user>
password=<pass>
share|improve this answer
    
gvfs-mount smb://myServer/myShare Error mounting location: Failed to mount Windows share –  theAngler Dec 19 '11 at 23:46
    
Make sure you are using the IP, not the host name. =) If you still receive the error verify the windows box is sharing correctly. –  vkcaspervk Jan 9 '12 at 2:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.