Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Umbrello Version 2.7.4, when creating a new class, private/protected attributes are not shown in class diagram view while public are shown. I have verified that show attributes option is checked. Is this a known bug ? How it could be fixed ?

Problem seems to exists since 2.4.4: http://lists.opensuse.org/archive/opensuse/2010-12/msg00011.html

Private/protected attributes should be present with a minus/tilde sign at the start of the line.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I am running the latest Umbrello from SVN (as of 2012/01/20, r1274951) and you can right-click on your class and Uncheck Show->Public Only. You can also change this setting at the diagram properties level or in the global Umbrello settings. However, I don't know if this is available is earlier versions...

Hope this helps

share|improve this answer
    
Also works on non-SVN version: right-click the class > properties > Display > Uncheck 'Public Only'. Private attribute are now be visible ;) –  Édouard Lopez Jan 30 '12 at 13:46

In the version I am using, 2.11, you need to right-click on your class, go to properties->display and uncheck Public Only.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.