Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have copy of Stargate in full HD weighing in at about 10.7 GB. Here is the full file info when opened in mplayer

mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Stargate.mkv.
libavformat file format detected.
[matroska,webm @ 0x9c6c2e0] max_analyze_duration reached
[matroska,webm @ 0x9c6c2e0] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (dca), -aid 0, -alang eng, 3/2+1
[lavf] stream 2: subtitle (pgssub), -sid 0, -slang eng
[lavf] stream 3: subtitle (pgssub), -sid 1, -slang spa
[lavf] stream 4: subtitle (pgssub), -sid 2, -slang eng
VIDEO:  [H264]  1920x816  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in ./
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [xv] 1920x816 => 1920x816 Planar YV12 
A:  15.8 V:  15.8 A-V: -0.002 ct:  0.039   0/  0 41%  2%  2.0% 2 0 

I've noticed the video is a little choppy, as if a few of the frames are displayed at the correct frame rate, then a subsequent one pauses for a moment. This is most apparent in scenes where there is a slow consistent movement (if the movement is erratic, or the scene is hectic, it is hard to tell).

When I open my system monitor, mplayer is only using 50% of my CPU and my total CPU usage never exceeds 80%. Likewise, mplayer only uses 40 MB of memory, and total memory usage never exceeds 60%. This leads me to believe that my system is not the bottle neck here, but the mkv file.

Is there a more definitive way for me to determine what is truly acting as the bottle neck? Furthermore, is there a way to turn on hardware acceleration and/or determine if hardware acceleration is enabled? If I could toggle this feature on/off, and the choppy playback disappears, then that will have answered my question.


System Specs:
OS: Ubuntu Oneiric 11.10
CPU: AMD Phenom II X4 970 Black Edition AM3 CPU
GPU: Radeon HD 4670
RAM: 4 GB DDR3
share|improve this question
    
Ubuntu plays HD video just fine, what is your CPU? I believe (and hopefully i'm wrong) that in Linux the decoding is made with the CPU and not the GPU like in Windows. –  Uri Herrera Dec 18 '11 at 20:46
    
@UriHerrera I added some system specs –  puk Dec 18 '11 at 20:51
    
@UriHerrera, GPU decoding is partly supported but support is very variable. Check into VDPAU (NVidia) and VA-API / XvBA if you're interested :) To the OP, you could try playing this in VLC with 'hardware decoding' turned on - that should use some hardware capabilities of your card, it would be interesting to see if it was any different. –  Caesium Dec 18 '11 at 21:32
    
You could look into enabling vaapi for your ati card & using a vaapi enabled mplayer. Otherwise use mplayer2 instead of mplayer, mplayer2 supports multithread H.264 decoding –  doug Dec 18 '11 at 21:33
    
@Caesium I turned hardware decoding on (and yes, I restarted VLC =P ) and it did not increase performance –  puk Dec 18 '11 at 21:37
show 2 more comments

closed as too localized by Luis Alvarado Mar 14 '13 at 16:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.