Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I start Chromium the program just disappears shortly after the tabs have loaded.

I have a fresh install of ubuntu 11.10 that I installed it using the wubi installer. Chromium worked fine when I first installed it. Things I can remember doing before it stopped:

  • I installed 200+ ubuntu updates
  • I synced chrome with my google account (bookmarks etc)
  • Installed and removed eclipse

I have tried un-installing and re-installing Chromium but the problem persists.

Where can I look to diagnose the cause of the crashing?

UPDATE - Here's what the console spits out:

matt@ubuntu:~$ chromium-browser 

(chromium-browser:2023): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(chromium-browser:2023): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(chromium-browser:2023): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(chromium-browser:2023): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
[] Gtk: gtk_widget_size_allocate(): attempt to allocate widget with width -2147483648 and height 1026
chromium-browser: /build/buildd/cairo-1.10.2/src/cairo-surface.c:1287: cairo_surface_set_device_offset: Assertion `status == CAIRO_STATUS_SUCCESS' failed.
share|improve this question

closed as off topic by Jorge Castro, Marco Ceppi Feb 6 '12 at 0:06

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

run chromium from the command line and post any errors – bodhi.zazen Dec 18 '11 at 19:32
updated. width of something seems to be set to nonsense value – matt burns Dec 18 '11 at 19:49
If no one has an answer, file a bug report. – bodhi.zazen Dec 18 '11 at 19:53 – jacopoL Jan 12 '12 at 10:52
up vote 5 down vote accepted

Short answer

  1. Start Chromium from a terminal with chromium-browser --password-store=basic
  2. Log in to a web page (in my case, gmail)
  3. Close Chromium
  4. It should now start normally.


I found the bug is already reported here. My default starting page was the gmail login page (it's password pages that cause the crash). I was able to start the program so that it stays open with the option '--password-store=basic'. Doing this seemed to fix some problem with my synced password keystore.

share|improve this answer
Thank your for posting back that information. – bodhi.zazen Dec 18 '11 at 20:10

What will help for many programms in config problems

In cases something really doesnt work u can try not removing but Purging what means deleting also configuration files of programm.

sudo apt-get purge chromium-browser

then try after installing again start and if not still working then delete folder of configuration for that programm for specific user in this case

sudo rm ~/.config/chromium

and then starting should reset all and work.

share|improve this answer

Additionally to remove the

Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

error - try

sudo apt-get install gtk2-engines-pixbuf
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.