Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I noticed that video performance on my Thinkpad X100e was very poor compared to Windows 7, so I installed the ATI fglrx proprietary drivers by using the "Additional Drivers" dialogue box. The system has an ATI Radeon Mobility HD 3200 chip.

The result of installing the drivers is pretty devastatingly negative, with symptoms such as skewed content in windows, browser tabs and text boxes failing to refresh when their content changes. In fact, please excuse typos in this post, because I can't really see what I am typing. :)

I also notice that HD video playback performance is no better - perhaps even worse - than prior to installing the drivers.

Example of what I see: Distorted display on X100e with ATI drivers

Here's the output of fglrxinfo:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3200 Graphics 
OpenGL version string: 3.3.10237 Compatibility Profile Context

Output of lspci | grep -i vga:

01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]

I'm on Ubuntu 10.10 with kernel 2.6.35-22-generic-pae.

What can I try?

Many thanks, -R

share|improve this question
1  
Can you add the output of lspci | grep -i vga please! –  Nick HS Oct 22 '10 at 14:48
    
Done - updated post. –  rewbs Oct 22 '10 at 14:54
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, then please flag explaining that (as well as editing your question with any details you have). –  jrg Jan 25 '12 at 23:00

2 Answers 2

up vote 2 down vote accepted

Just do sudo aticonfig --initial after installing the the HD3200 driver and you're done.

share|improve this answer

To revert back to the open source drivers it should be a simple matter of disabling the Proprietary Drivers in the Additional Drivers application. After that you will need to restart (or at least logout and log back in).

Also take a look here for a bunch of xorg.conf options to tweak the FGLRX drivers. If I were you I'd setup a xorg.conf which would a) allow you to easily swap between the closed source and open source drivers and b) allow you to tweak the drivers more. To do so take a look at the Ubuntu wiki

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.