Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought samsung scx3200 multifunction printer i think that printing is easy as Ubuntu define the printer by default but what about scanning i have found a default installed program called simple scan but it didn't recognize the scanner

simple scan

and i have installed the driver from here but the same

samsung driver

then what to do ???

share|improve this question
2  
there is a long thread here on these packages - this post looks interesting. I dont have your printer to test with hence the comment. Good luck: ubuntuforums.org/showpost.php?p=9887879&postcount=500 –  fossfreedom Dec 18 '11 at 15:28
    
thanks works like magic –  Naruto Dec 18 '11 at 19:38

5 Answers 5

up vote 5 down vote accepted

For 11.10

Download the official Samsung Unified Driver from this page

Installed the Samsung drivers following the steps in the Samsung manual, here (see the chapter "Getting started", section "Supplied software");

Add in /etc/sane.d/xerox_mfp.conf these two lines:

# Samsung SCX-3200
usb 0x04e8 0x3441

and in /lib/udev/rules.d/40-libsane.rules these two lines:

# Samsung SCX-3200
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="3441", ENV{libsane_matched}="yes"

source

share|improve this answer
    
sorry haven't seen your answer while writing the answer to other's –  Naruto Dec 18 '11 at 20:39

For 12.04

In 12. 04 the printer worked out of the box. To get the scanner working I didn't have to download anything. I just edited a few files:

I added to /lib/udev/rules.d/40-libsane.rules the following:

# Samsung SCX-3200
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="3441", ENV{libsane_matched}="yes"

And to /etc/sane.d/xerox_mfp.conf, I added

#Samsung SCX-3200
usb 0x04e8 0x3441

Then I did a

sudo service udev restart

Unplugged and plugged the scanner and all was working.

note: for SCX-3405 use 344f instead of 3441

share|improve this answer

As explained in ubuntuforums.org a nice guy prepared a repository for easy driver installation. Very important: you must have completely removed all prior installations of the Unified Linux Driver before using the packages. Here I quote his instructions:

  1. Add the following line to your /etc/apt/sources.list, by editing the file using sudo, or by using Synaptic:

    deb http://www.bchemnet.com/suldr/ debian extra
    
  2. Install the GPG key for the repository. Execute in a terminal as sudo:

    wget -O - http://www.bchemnet.com/suldr/suldr.gpg | sudo apt-key add -
    
  3. Refresh your repository listings (apt-get update or in a GUI), and then you should see the NEW suld-* and OLD samsungmfp-* packages corresponding to the Samsung Unified Linux Driver.

  4. Install the latest available drivers suld-driver-4.01.17. Printer and Scanner should now be usable with the distribution now. If you also would like to have the Samsung Unified Driver Configuration GUI, do install suld-configurator-2-qt4.

  5. If you are trying to use your printer as a scanner, you will need to add yourself to the "lp" group after installing the appropriate packages. You will then to log out and back in for the change to take effect.

    sudo usermod -a -G lp yourname
    

Now your scanner should work with simple scan. If not lookup above mentioned page for troubleshooting.

share|improve this answer

For 10.04

1- Downloaded the official Samsung Unified Driver from this page.
2- install the Samsung drivers by accurately following the steps in the Samsung manual. samsung-site manual
3- open the terminal and write this command gksu gedit /etc/sane.d/xerox_mfp.conf, write down the password and add this two lines to the file:

                 # Samsung SCX-3200
                 usb 0x04e8 0x3441
it should be near to this samsung-driver save the file and close it.
4-also write this command in the terminal gksu gedit /lib/udev/rules.d/40-libsane.rules and add these two lines:

       # Samsung SCX-3200
       ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="3441", ENV{libsane_matched}="yes"

   save and close the file.

it should be near this samsung-driver restart and it should work.
a picture of my scanner scanner2 scanner1 Thanks to @fossfreedom and this thread

share|improve this answer

Try setting the printer from http://localhost:631, as the samsung configurator installation insists on port ipp.

When I did this, the CUPS server at the time recognized the USB printer, and put the PPD in /usr/share/ppd/custom/samsung.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.