Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've switched to XMonad as my window manager. Sometimes when I put my laptop to hibernate, it's hanging and won't shut down. I have to force it off by pressing the powerbutton for 5 seconds.

After I boot again, I can't connect to the internet. I have to logout, go to gnome, and after logging in, I rightclick the network applet icon and select the enable networking options. After that, my internet is working again.

Is there a way to do this via the command line or another option?

share|improve this question
add comment

4 Answers

up vote 3 down vote accepted

You can customise xmonad with status bar and tray apps for utilities like network-manager which need tray icons.

This guide, for example, details how to set up xmobar and trayer, among other things.

share|improve this answer
    
It seems a good sollution. The only problem is that I can't seem to get trayer on the top of my screen. It just doesn't appear. –  Ikke Oct 28 '10 at 12:47
    
Temporarily fixed the problem by adjusting my xorg.conf to allow for only one screen. See askubuntu.com/questions/10005/… –  Ikke Oct 28 '10 at 15:04
add comment

You can use nmcli (part of NM) or cnetworkmanager Install cnetworkmanager to control NetworkManager from the commandline.

BTW: you can configure Monad to use a panel or such (but maybe that's not what you want).

share|improve this answer
add comment

I find after improper shutdowns that the /etc/NetworkManager/nm-system-settings.conf often has Managed=False set. When you go into GNOME and hit that checkbox, all you're doing is toggling that to True. You can do it with a text editor too.

share|improve this answer
    
Setting it to true doesn't solve the issue, and it seems enableing networking doesn't set it to true –  Ikke Oct 23 '10 at 13:18
add comment

It sounds like you've killed the network-manager daemon. You can restart it by doing sudo service network-manager start. However if you're not using network-manager you can always remove it all together (and probably eliminate this issue).

share|improve this answer
    
The network manager is still running (NetworkManager process). And I use nm-applet to get wireless connection. –  Ikke Oct 23 '10 at 13:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.