Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have update manually the kernel on ubuntu 11.10 and now I have this messages on boot:

Cache read/write disabled: /sys/kernel/security/apparmor/features interface file missing. (Kernel needs AppArmor 2.4 compatibility patch.)

The kernel version is 3.1.5 with -pf patchset and apparmor enabled in kernel config ? Any suggestions ?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

The upstream kernel needs to be patched with an AppArmor compatibility patch to be able to work with the AppArmor userspace tools.

share|improve this answer
    
Right ! Just download the 2.7 tarball and apply the patch to bare 3.1 then -pf patchset, compile again now it's working. Thanks ! –  LopanRS Dec 18 '11 at 16:34
    
Would you mind providing links to these patches and tarballs and such so that other uses such as myself can learn from your accomplishments? <3 –  earthmeLon Apr 15 '12 at 11:10
    
my.opera.com/lopanrs/blog/2011/11/30/… There's a link to apparmor patch. The blog are in Portuguese, google translate it well. –  LopanRS Apr 16 '12 at 11:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.