Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i decided to install ubuntu also on my desktop PC (Windows has been exorcised from my life) but i am having some problems i didn't have with previous hardware configurations.

My display is a Samsung SyncMaster SA300, on windows vista the maximum resolution (1920x1080) worked well, but now, ubuntu (after installing fglrx drivers) tells me that the maximum resolution is 1600x1200

I googled a lot last night, and i found a lot of people solving this (on different displays though) with xrandr.

I was not able to do it, because xrandr keep complaining "you goddamn maximum resolution is 1600x1600".

What xranrd clean command say is:

    mattia@fatdesktop:~$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 1600 x 1600
DFP1 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)
CRT2 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1600x1200      60.0*+
   1400x1050      60.0  
   1280x1024      60.0     47.0     43.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       60.0  
   1152x864       60.0     47.0     43.0  
   1280x768       59.9     56.0  
   1280x720       60.0     50.0  
   1024x768       60.0     43.5  
   800x600        60.3     56.2     47.0  
   720x576        50.0  
   720x480        60.0  
   640x480        60.0  
TV disconnected (normal left inverted right x axis y axis)
CV disconnected (normal left inverted right x axis y axis)

Then according to other internet posts and forums:

    mattia@fatdesktop:~$ cvt 1920 1080 60
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

So now i have to add that modeline

mattia@fatdesktop:~$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
mattia@fatdesktop:~$ xrandr --addmode CRT2 1920x1080_60.00

And here comes the pain:

mattia@fatdesktop:~$ xrandr --output CRT2 --mode 1920x1080_60.00
xrandr: **screen cannot be larger than 1600x1600 (desired size 1920x1080)**

See? screen cannot be larger than 1600x1600 (desired size 1920x1080)

At this point, the 1920x1080 option appears inside the resolution choice menu (the graphical one). But last night, when i tried to select it, my screen went black, and i had to power off the pc.

Any clues? am i on the wrong path?

share|improve this question
    
I don't know if it will help but: 1. Gnome-shell shows screwed up graphics, in particular the top bar shows vey strage colors and letters are not correctly displayed 2. I couldn't install post-release fglrx drivers, but the other one, which i think its fine too –  fatmatto Dec 18 '11 at 10:38
    
Another thing worth to note, sometimes, the display flickers to black... looks unstable. Could it be a Ubuntu related problem? switching to fedora could solve the problem? –  fatmatto Dec 18 '11 at 12:49

1 Answer 1

up vote 0 down vote accepted

I believe your trouble is your "virtual screen" size. I was getting the same message when trying to setup dual monitors. The solution I found was changing the "virtual screen" to a larger size.

To do so I had to modify /etc/X11/xorg.conf
sudo leafpad /etc/X11/xorg.conf

Mine orignally looked like this

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

I added the below to modify the virtual screen size

SubSection "Display"
    Virtual 3840 1920
EndSubSection

See the screenshot below and note that the "maximum" is now increased. enter image description here

In the end my xorg.conf ended up looking something like

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
    SubSection "Display"
        Virtual 3840 1920
    EndSubSection
EndSection

Section "Module"
    Load    "glx"
EndSection

Hopefully you can just change the "3840 1920" to "1920 1080".

Of course you should backup your xorg.conf before making changes. I know I had to restore it about 20 times till I figured it out.

Further explanation is on this site

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.