Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I connect my Samsung Galaxy SII with USB cable my DCIM folder looks empty although I can see my files on phone. Do you have any idea what would be the problem?

On computer:

Empty folder

On phone:

enter image description here

share|improve this question
    
Have you connected the SGSII via Mass storage?, i get Filesystem 11GB when i connect mine. –  Uri Herrera Dec 17 '11 at 22:47
    
It is connected as MTP. –  Olcay Ertaş Dec 17 '11 at 22:54
    
Got to Settings>Applications>Turn on USB debugging mode. I don't really remember how was it with Samsung ROM's as I'm Using MIUI but look trhough the Application settings and the Storage Settings. –  Uri Herrera Dec 17 '11 at 22:56
    
A workaround would be to use Kies Airweb interface , so you can connect through a web browser and download your files to your PC. –  Uri Herrera Dec 17 '11 at 23:03

4 Answers 4

The way to get direct USB access to files on the Galaxy is as posted here: http://www.tuxtrix.com/2011/07/how-to-access-samsung-galaxy-s-ii-usb.html

This is not about USB debugging but simple telling the Galaxy to connect its storage to PC via USB:

On the Galaxy do: Menu -> Settings -> Wireless and network -> USB utilities -> Connect Storage to PC

share|improve this answer
    
You are talking about ICS way –  Olcay Ertaş Mar 11 '12 at 13:02
    
I don't have "USB Utilities" in my options. –  Mittenchops May 29 '13 at 11:53
up vote 3 down vote accepted

While USB Debugging option is disabled Samsung Galaxy SII is working as a MTP device and in this case Ubuntu can not see files on the phone. When I enable USB debugging option and connect my phone with USB cable Ubuntu recognise my phone as USB mass storage device and I can access my files.

share|improve this answer

Could not get Galaxy SII to work via Kies wireless or plugged in to USB directly on Ubuntu 11.10. As others mentioned, the way I fixed was going to "Settings>Applications>Development>Turn on USB debugging" on my phone and then reconnecting with USB cable to my laptop. I put my music in '/media/audio' (copied from my local ~/music folder) and it just worked! Kies would be nice to get working though, so I wouldn't even need a cable...it connects and I can see all my content...it just won't upload anything. Thanks for the answers guys, this has been bugging me for weeks since I got my S II.

share|improve this answer

There is a PPA with upstream MTP patches for gvfs built in. Upgrading to this is fairly simple but may be unstable or you might not trust it. That is your decision to make.

Installing it is fairly simple:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update
sudo apt-get dist-upgrade

You'll want to log out and in (or restart) after doing that but you should then be able to use MTP from within Nautilus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.