Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I tried to install GNOME Shell (using Ubuntu Software Center) this error showed up.

Error message

The message says:

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

Here the dependencies:

The following packages have unmet dependencies:

gnome-shell: Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) but 1:1.0-0ubuntu3 is to be installed
             Depends: libpulse0 (>= 1:0.99.1) but 1:1.0-0ubuntu3 is to be installed
             Depends: libxfixes3 (>= 1:5.0) but 1:5.0-4 is to be installed

So can you help me install GNOME Shell?

share|improve this question
are you installing the 'gnome-shell' package using the Software Center? If not, can you try that? – Tom Brossman Dec 17 '11 at 19:15
Although it may not initially look like it, you can scroll that error message's details down. Exactly what dependencies is it complaining about? Alternatively, if it is a lot to write, you can try running sudo apt-get install gnome-shell in a terminal and paste the output in an edit, or use – Christopher Kyle Horton Dec 17 '11 at 20:15
with terminal I wrote that command ,but it printed an error says The following packages have unmet dependencies: gnome-shell : Depends: gnome-icon-theme-full but it is not going to be installed Recommends: gnome-session-fallback but it is not going to be installed E: Unable to correct problems, you have held broken packages. I wrote sudo apt-get install gnome-icon-theme-full but with another error : The following packages have unmet dependencies: gnome-icon-theme-full : Depends: gnome-icon-theme (= 3.2.0-0ubuntu1) but 3.2.0-0ubuntu2 is to be installed. – creative Dec 18 '11 at 6:20
Have you tried running updates lately? If that returns an error, it is possible you might need to fix your package dependencies. – Christopher Kyle Horton Dec 18 '11 at 7:51

I had similar problem with gnome-session-fallback instalation. The problem seems to be because you try to install something that depends on old versions of

libpulse-mainloop-glib0, libpulse0 and libxfixes3

. Try to uninstall those three and then install the gnome shell. The dependencies should get installed in older versions as a result.

share|improve this answer
The problem is that removing these breaks Unity, Cinnamon, etc. – Robbie Wxyz Sep 30 '14 at 17:38

I was getting the same error, and I compared the package versions in a fresh install with those of the mirror and noticed a discrepancy.

Turns out that in my default Oneiric install, updates are not enabled by default.

To fix this,

  1. Open the Software Sources application.
  2. Go to the Updates tab and enable oneiric-security and oneiric-updates.
  3. Open a terminal window and run sudo apt-get update.

Now you will be able to install gnome-shell and all its dependencies without problems.

At least that fixed the exact same error message that I got.

share|improve this answer

try to install from terminal

sudo apt-get install gnome-shell

if any dependency is missing , it will be displayed too, install them too. after this you might be good to go.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.