Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a new 27 inches monitor, I plugged it in and ubuntu started with my old monitor resolution (1440x900). So I went to the nvidia-xconfig (the default config tool wont work because I use a nvidia card), I set the resolution to auto and it selected 1920x1200 (I also tried selecting it manually and other resolutions higher than 1440, the problem is the same), but on screen the monitor only seems to be showing a 1440x900 rectangle and the rest of the screen (right bottom) is black, here's a screenshot:

http://i.stack.imgur.com/z4GQn.png

Any resolution higher than 1440x900 have this problem, I have also tried pressing the "auto adjust" button on the monitor but that wont work. I am using ubuntu 10.04 with kernel 2.6.32-35-generic.

Any ideas how to solve it?

Update:

Here's my xorg.conf:

http://pastebin.com/2EGQA65p (It looks like it still have the settings for the 2 monitors from when I have them both connected, but now I have only the 27 inches one plugged in since a few days, I'd like to use both monitors at the same time but first I want the new one to work fine on full res)

New monitor: Samsung P2770H (27 inches)

Old monitor: LG L192WS (19 inches)

Video Card: XFX 8600GT

NVidia Driver Version: 195.36.24

Also wanted to add that the mouse cursor can move over the black area without disappearing.


Update2:

I went into nvidia-xconfig and changed the resolution to 1920x1200, then I clicked "Save to X configuration file", and unchecked the "merge with existing file" checkbox, this is the xorg.conf file created:

http://pastebin.com/RVrBDAv4

After this I used "sudo restart gdm", and when the login splash appeared it was in 1920x1200 !, I was so happy, but then I logged in, and the screen changed to 1440x900 (screen filled, no black borders). nvidia-xconf shows 1440x900 as the current resolution but xorg.conf still has 1920x1200 set.

What could be forcing the resolution to change after I login? (solved)


Update3:

What was changing the resolution was monitors.xml file, I edited it using the values 1920x1200, and this time after login the resolution doesn't change but the black border like in the screenshot appears. So the problem is still the black border in the bottom right.


Update4:

I found the cause!, if I kill compiz the resolution works fine so I went to System > Preferences > Appearance > Visual Effects, and selected none. Now it works fine!. I am still curious what's causing it, I set it to normal and the problem occurs, I then went to CompizConfig Settings Manager and deselected all the effects, but the problem persists, the only workaround I found is setting the Visual Effects to none.

What else could I try to find the real root of the problem? Because I am still having some problems like when I put the mouse hover the shutdown tray icon all the icons changes positions and also colors, it's really weird.

share|improve this question
    
Interesting. What monitor and what nvidia card ? Also , can you pastebin your xorg.conf –  bodhi.zazen Dec 17 '11 at 16:54
    
@bodhi.zazen I updated the question with that info, thanks. –  Uoplem Dec 17 '11 at 17:15
    
You have two screen sections in your xorg.conf. Why is that? –  Nathan Osman Dec 17 '11 at 18:59
    
@GeorgeEdison I haven't edited the file manually so I am not sure, I only used nvidia-xconfig, at first I had the 2 monitors connected to the video card, now I have only the new one. –  Uoplem Dec 17 '11 at 19:03
    
Do both show up in nvidia-xconfig? –  Nathan Osman Dec 17 '11 at 19:20

1 Answer 1

up vote 2 down vote accepted

I didn't find a solution but a workaround, I had to disable compiz Visual Effects.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.