Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently retrieved my laptop back from the shop for a hardware issue (problematic screen). I discovered that I am now unable to connect to my wireless network at home. The wireless network appears and registers that I am connected, but am unable to connect to the internet (webpage is not available).

Other computers are able to connect no problem (my old powerbook for example). Now what is curious about this issue is that when I plug the ethernet cable into the laptop, I'm able to connect via wired and the wireless network. In that, after I connect to the wired connection and switch to the wireless, and unplug the ethernet cable, I'm suddenly able to surf the net no problem via wifi.

Once I restart the computer, however, the problem resurfaces and if I want to connect via wifi, I have to do the aforementioned solution over again.

I tried a number of things: updating and upgrading from 11.04 to 11.10 and reinstalling my wireless driver. Neither of these things resolved the issue. Someone please help! Clearly I'm not the most technologically savvy, but am willing to stretch my mind a bit to try to resolve this finicky issue.

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Dec 17 '11 at 17:06

1 Answer 1

up vote 0 down vote accepted

Have you tried connecting to an IP address, to check if it's a DNS configuration issue?

Try typing 64.34.119.12 in your address bar when connected via wireless. If this website comes up, your wireless access point doesn't set up your dns servers correctly (had the same problem with a broadcom wireless card on ubuntu 10.10)

share|improve this answer
    
I did as you instructed and I was directed to stackoverflow.com. Does this mean that my wireless access point doesn't set up my dns servers correctly, as you say? How do I resolve this issue? –  Jeffrey Dec 17 '11 at 14:57
    
this means that you have an active internet connection but your laptop does not get the configuration to translate the code "stackoverflow.com" to the IP needed. You need to check the DNS configuration when your ethernet cable is plugged in and copy it to your wireless connection configuration, or set up google's DNS servers (like this : [link] blog.sudobits.com/2011/07/17/…) –  Spyros Mandekis Dec 17 '11 at 15:19
    
i'm sorry delete the "[/link]" in the end of the url –  Spyros Mandekis Dec 17 '11 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.