Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Synaptic I get the following error message:

E: The package hl1440lpr needs to be reinstalled, but I can't find an archive for it.
E: Internal error opening cache (1). Please report.

Upon accepting the message, Synaptic quits.

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

What set of instructions / web site were you following and what problem were you having ? –  bodhi.zazen Dec 17 '11 at 5:29

1 Answer 1

Well we may need a few steps to fix this.

Start with

sudo dpkg --remove --force-all hl1440lpr

If that fails ...

# become root
sudo -i
cd /var/lib/dpkg/info
rm -rf hl1440lpr*

dpkg --remove --force-remove-reinstreq hl1440lpr


Confirm apt-get is fixed

# should return no errors
sudo apt-get update
share|improve this answer
I ran into this situation when I was upgrading to Ubuntu 12.10 but accidently suspended the computer midway. Upon waking the computer, the upgrade had (obviously) failed and a red icon appeared next to the battery meter which said that E:The package xterm needs to be reinstalled, but I can't find an archive for it. Once I applied the suggestion here, sudo dpkg --remove --force-all xterm everything was fixed. Thanks! ps, it would be nice if you could edit sodo to say sudo, I wouldn't nitpick but that would derail someone who didn't know anything about linux. –  dylan murphy Oct 23 '12 at 21:55
Thank you bodhi.zazen. Your solution worked for my faulty brother-driver; dcpj4110dwlpr. –  v2r Dec 27 '14 at 20:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.