Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Lenovo T420s with Nvidia 4200M + Intel HD 3000 graphics cards. When I attach the laptop and monitors to the docking station, nothing happens - the monitors are not recognized.

What I have tried that did not work:

  1. all variations of the Display settings in BIOS (Dedicated, Optimus, Integrated)
  2. installing proprietary drivers
    • then, I installed nvidia settings and ran sudo nvidia-xconfig after which I had to remove /etc/X11/xorg-config before x would work again.
  3. using a vga cord (ubuntu recognized monitor but did not send any video there)
  4. removing proprietary Nvidia drivers
  5. reinstalling Ubuntu
  6. using Unity 2D and xfce

I have googled quite a bit with little success. I have been told by IT to install windows 7 and use Ubuntu as a VM. What are my other options?

share|improve this question

1 Answer 1

I have the same problem, and I have done some research and partially solved it. However, I am still working on a complete solution.

The hardware:

  • Thinkpad T420s with Nvidia 4200M + Intel HD 3000 graphics
  • Thinkpad dock.

The symptom:

  • T420s can't recognize the external display connecting to any DVI port on the dock.
  • It can recognize the external display through VGA port on the dock. However, the quality is poor.

The root cause:

  1. T420s has Nvidia card connecting to DVI port while Intel card to VGA port on the dock.
  2. Unlike Win 7, Ubuntu can't switch between Nvidia card and Intel card. By default, only Intel card is being used.

The solution:

  1. Put T420s to dock and connect the external display to DVI port.
  2. Goto BIOS, find "Display", change the configuration to "Discrete Card" and "Disable Nvidia Optimus". Now T420s is forced to use Nvidia card.
  3. Download and install Nvidia driver for Linux. Google the detailed instructions.
  4. After the installation, Do "sudo nvidia-settings".
  5. In the pop-up window, "X Server Display Configuration", Click "Detect Displays". You will be able to see the external display now.
  6. In the same page, change Configuration to "TwinView", Resolution "Auto" or the native resolution of T420s, say, 1600x900.
  7. Click "Apply", you will be able to see the external display desktop.
  8. Click "Save to X Configuration File". A new /etc/X11/xorg.conf will be created.

Remaining Issues to Resolve

There are still a couple of issues. I'm still working on it. Most likely, a proper xorg.conf will solve them.

Hope it helps.

share|improve this answer
    
have you had any luck finding a complete solution? –  David Jan 14 '13 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.