Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am attempting to ssh into my home laptop (lappy) from my work laptop (lappy2) so I can run things, transfer files, feel good about having the skillz necessary to set up a server, etc.

I have told my AT&T Uverse 2wire router (3801HGV) to open port 22, and it's showing that port 22 is open. I have tried ssh user@routerIP, ssh user@routerIP:22, ssh user@lappyIP, and ssh user@lappyIP:22, replacing all the relevant words with my real credentials of course. None of these things worked.

When I go to, no ports appear to be open at all. I checked 22, 25, 80, and a few others.

Lastly, I have tried the instructions here with a middle computer (hpc) that I use at work, and this didn't work either. For the record, lappy and lappy2 can both connect to hpc from anywhere I have internet access.

Is there anything else I can try? Thanks.

share|improve this question
Nothing Ubuntu about that! :) But I found the User Guide: There's a firewall and you need to use port forwarding. – user8290 Dec 16 '11 at 19:55
I have told my AT&T Uverse 2wire router (3801HGV) to open port 22 to allow ssh. It still doesn't work. – Chad Dec 16 '11 at 21:45
up vote 1 down vote accepted

Well, I figured it out. It was a really dumb mistake too. I needed only to install openssh-server on the destination machine (lappy). This completely solved the problem.

I was waiting to post this because it wouldn't allow me to answer my own question until some time had elapsed.

Also, I found out that if you want to use non-standard ports, you must tell ssh-server to listen with sudo /usr/sbin/sshd -p <port>. I set it up on two machines so I had to specify an arbitrary port on the second machine as 22 was used by the first. Also, the command must be executed with an absolute path for some reason.

share|improve this answer
I will be accepting this as the answer in 20 hours when it allows me to do so. – Chad Dec 17 '11 at 23:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.