Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to see smaller pop-ups but where have I to go to configure this?

For example, when power manager pops up: I want a smaller notification

share|improve this question

3 Answers 3

up vote 8 down vote accepted

Depending on the OS version, one may have to to replace the existing Lubuntu notify pop-up with the XFCE equivalent:

XFCE Popup enter image description here

Lubuntu Popup enter image description here

It has a simple config GUI (xfce4-notifyd-config) - by default the notification size is smaller - similar to the Unity pop-ups.

enter image description here

Since all the desktop popups work with the same underlying libnotify - using the XFCE variant in Lubuntu is fully compatible.

to install

Install the XFCE Notify Pop-up if you don't see it in your list of installed software (dpkg --get-selections | grep "xfce4-notify"):

sudo apt-get install xfce4-notifyd 

11.10 users

It doesn't work with notify-osd if you have this also installed:

sudo apt-get remove notify-osd

Logout and login for the changes to take effect.

12.04 users

You need to remove notification-daemon as described using this Q&A:

12.10 users

Notification-daemon have been replaced for xfce4-notifyd on the default installation

In other words, it's the default. You don't have to install or uninstall anything and the notifications are already smaller. But you can still do useful things such as choose

  • where the pop-ups appear
  • the duration pop-ups stay visible
  • their theme and
  • opacity

Just press Alt+F2 to bring up the Run window (or click Run in the main menu), type xfce4-notifyd-config, and hit enter to get the GUI and make your choice.

Alternatively, if you want to use the mouse, you'll have to do a bit of extra work to get xfce4-notifyd-config to appear as an option in Main Menu, Preferences:

  • copy over /usr/share/applications/xfce4-notifyd-config.desktop to ~/.local/share/applications
  • open the copied file with Nano (or any other text editor)
  • navigate to near the end of the file and look for the line OnlyShowIn=XFCE
  • edit that line to read OnlyShowIn=XFCE;LXDE
  • save the changes

You should now see Notifications in Main Menu, Preferences. Clicking on that will bring up the GUI (that could be also accessed by typing xfce4-notifyd-config in a terminal or in the dialog box obtained by pressing Alt+F2).

share|improve this answer
    
it's smaller than the lubuntu's popup. –  maniat1k Dec 19 '11 at 9:13
    
This was a super helpful answer! Thanks so much! –  algebralives Jul 23 '12 at 3:56

Install notifyosdconfig

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install notifyosdconfig

Full Tutorial: http://www.webupd8.org/2011/05/configurable-notifyosd-bubbles-for.html

Screenshot

From tutorial

share|improve this answer
1  
... in my testing - this works in ubuntu but doesnt work in lubuntu :( Can you confirm this? –  fossfreedom Dec 16 '11 at 23:46
    
Wow, that would be a drag if it does not work on Lubuntu, I am asking in #lubuntu –  bodhi.zazen Dec 16 '11 at 23:53
    
Ok I gave it a chance and it does not work @fossfreedom is right. –  maniat1k Dec 19 '11 at 9:09

By coincidence I discovered that notifyosdconfig works with xfce4-notifyd, but you have to remove notify-osd and the notification-daemon. FYI: I'm on Lubuntu 12.10

Sorry: disregard my answer, turned out that it doesn't change the settings of xfce4-notifyd :-(

share|improve this answer
    
If it didn't work, you might consider deleting it. Also, don't use bold for commands, whether its just names or not. –  Seth Feb 10 '13 at 1:47
    
Yes, I too feel this answer may not be necessary since it specifies 12.10 and 12.10 doesn't need any fixes because the pop-ups are handled by xfce4-notifyd by default. –  user25656 Feb 10 '13 at 2:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.