Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I' ve just bought a dell latitude 5520 and installed 11.10, my trouble is that the fan is noisy which is not regular.

It is quiet for 1 minute and then speeds up and slows down every 4 seconds for 1 minute : it's very annoying.

I tried i8fan things on the Internet but i didn't solve my problem, it seems to work better in windows 7 but i don't use it a lot.

Dell technician came and changed the motherboard and the fan but it's still the same.

I have to put music on when i'm on my computer...

Anyone have the same problem or a solution?

share|improve this question
    
can you check your CPU usage e.g. using the program top? In general the behaviour you explained is normal, depending on the heat your system produces. –  Michael K Dec 16 '11 at 16:35

3 Answers 3

For me the problem was i8kmon. I sorted it out by stopping i8kmon:

sudo service i8kmon stop

I also edited /etc/default/i8kmon and set ENABLED=0 to disable it at startup.

share|improve this answer

I believe the issue is kernel-level, and have confirmed the following works (in stopping the fan, and running less often) with kernels 3.2 - 3.5. Though on Inspiron 15R 5520, the root cause is likely the same.

echo "min_power" | tee /sys/class/scsi_host/host*/link_power_management_policy

Typically one only needs to do it on host0, but it doesn't hurt to do it as above, just to be sure. Yes, as it's strange as it sounds, the only way I could get the fan to quite down is with enabling SATA ALPM (Agressive Link Power Management) -- the min_power used above. Unfortunately, medium_power doesn't help. max_performance is the default and is what keeps the fan always running for some odd reason. But, since this happens to be a laptop, this may be a good idea anyway as it shaves a good 0.7-1.5Watts off your power consumption when you running on batteries.

Another thing to help with power/heat, is power savings options of the integrated GPU - Intel HD 4000 kernel module; i915

options i915 modeset=1 i915_enable_rc6=1 i915_enable_fbc=1 lvds_downclock=1 semaphores=1

modeset is necessary (along with opensource radeon driver) for vgaswitcheroo to work. that way, you can disable the discrete graphics when not needed via:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

echo MIGD > /sys/kernel/debug/vgaswitcheroo/switch

echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

This 2nd OFF may not be needed, unless scripting, to avoid possible blanking on resume. You may want to run this in startup, for default boot to be more energy efficient (and quieter fan operation).

share|improve this answer

I had a similar issue on my Inspiron 5100 (long time ago). I solved it with lm-sensors. You can install this package and then use sensors to view te sensor values.

You can also use it to regulate the fan speed. But be careful, you can burn your CPU if it's not finely cooled !

I found it: http://ubuntuforums.org/showthread.php?t=42737

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.