Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bad tearing while watching video in Ubuntu 11.10. I tried to use both smplayer and vlc, but none of them helped. In fact I see tearing only in rips, there is not such problem while watching Blu-ray movies. Though maybe i'm just not very attentive. Can anybody help me with this? I have 32-bit version of Ubuntu. Videocard is GTX460 768mb. I use hardware acceleration in players (vdpau). Enabling vsync in CCSM doesn't help.

share|improve this question
1  
Maybe this solution for the Intel problem helps here too? –  htorque Dec 16 '11 at 11:15
1  
Thank you! It has helped. But after enabling buffer swap another "problem" has appeared. The process of moving windows has become not very smooth. It's not actually a problem, but not very pleasant. What can I do? –  Mad_Bear Dec 18 '11 at 8:34

3 Answers 3

Yes I finally have a solution for you it took a bit of digging, you have to use compiz settings manager. Go to Utilty-->workarounds(make sure this box is checked then go to "don't wait for video sync" check the box then go to "force full screen redraws" now check this box. Also some other this you could do is in the ccsm go to "OpenGL" click on the texture tab put best then go to "Composite" and uncheck "detect rate" then crank up the refresh rate to anything higher than it's default that is set at 50 I set mine to anything beyond 60. This solved all my problems. Hope this helped. :)

share|improve this answer

I've found that 'Force full screen redraws (buffer swap) on repaint' works for me. Nvidia version 295.49 in ubuntu 12.04 stills seems a little jerky to me though.

share|improve this answer

In order to stop video tearing for the poor newbies to Gnome shell or just Ubuntu 12.04 you must enable yourself to be a super user by typing in terminal.

$ sudo nautilus

Then go to system folder go to etc folder then scroll down to environment (Note: this is not a folder but it is a system file, it looks sort of like a page) Once you click on this you will see this line

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

Now just type below that line (or copy and paste)

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

then type

CLUTTER_VBLANK=True

This should take care of the tearing. They don't quite explain how to do this for newbies to LINUX at all, the writers expect every one just to know how to do this because they think everyone is a programmer.

This little patch should take care of everything. One last thing: please restart your computer and then play your movie or youtube vide.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.