Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My GUI has changed into some crappy looking theme, I don't know why it happened and I want to get the default looks back!

enter image description here

It happened after I was mucking around trying to get the purple grub menu splash to go away, so that I could see dmesg during boot, and I followed the instructions in this accepted answer to do sudo apt-get remove plymouth-theme-* and reboot. Unfortunately, now I've got an ugly Gnome and ironically the bootloader splash screen remained anyway.

enter image description here

Of course I first tried sudo apt-get install plymouth-theme-ubuntu-logo plymouth-theme-ubuntu-text, which were the two that got removed by the previous step, but even after reboot it was still the ugly gnome.

Next I tried gnome-tweak-tool but it was all set to ambiance theme which should be correct. And then I tried lxappearance app which looked promising but didn't fix the problem either.

How can I get my old window and icons looks back?

share|improve this question
    
possible duplicate of Desktop forgets theme? –  Uri Herrera Dec 16 '11 at 4:12
    
The answers in that thread did not solve the issue for me, furthermore I am not running Ubuntu in a virtual machine –  wim Dec 16 '11 at 8:57
    
This is due to the same issue there gnome-settings-daemon crashes and the theme doesn't load. –  Uri Herrera Dec 16 '11 at 18:55
    
Not in my case it wasn't. –  wim Dec 17 '11 at 7:40
add comment

2 Answers 2

up vote 4 down vote accepted

After trying 101 things, the solution that finally worked for me was taking a backup of ~/.config/dconf/ and then removing it. This was regenerated again after the next reboot, with the default window and icons themes coming back.

Note: I also lost a few minor customisations I'd made, and had to redo them again manually.

share|improve this answer
    
You will loose more than some minor customisations! You'll loose all your unity settings for example. Please backup the folder before removing it. You should add this to your answer. –  mrcktz Feb 17 '13 at 19:12
1  
Of course, I actually did take a backup before deleting. I thought that was obvious enough that it goes without saying, but I've edited it into the answer now. –  wim Feb 18 '13 at 0:54
    
If it only was that obvious to all users ;) –  mrcktz Feb 18 '13 at 1:25
add comment

Today I felt the same anger, but after seeking in dconf-editor, I found a solution (without deleting any config files from your home dir!!!) If the gnome-settings-daemon running, start the dconf-editor and in the settings tree (left side of the window) look for the org -> gnome -> settings-daemon -> plugins. There are the key on/off switches, so go through on the topics, and put the pipes to the "active" boolean options. For example, my gtk-theme settings didn't do anything until I set the org->gnome->settings-daemon->plugins->xsettings->active to True!!! Also important the 'font', 'media-keys' (for laptop spec keys), etc. Where the default settings is 'True', there should it set to it.

Hope it'll works for the same victims (without erase the settings files and start anything from the beginning). And sorry for my English...:)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.