Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just installed Ubuntu 11.10 on my HP Pavillion DV6000 and my wireless will not connect. I been searching all over the Internet for answers so this is my last resort. Nobody can quite figure it out I've heard to get online and do updates cause i dont have a wired connection.

It reads my wireless and ask for passphase and then just cant connect. It keeps popping up every minute or so asking for the password. I have a Intel Corporation PRO/Wireless 3945abg [golan] network controller.

Im new to ubuntu im using a mobile hotspot for my wireless i then went to edit connections found my hotspot then went to the wireless security it is WPA & WPA2 Personal i made sure the passphase is right. The wierd thing is i upgraded from ubuntu 10.10 and the wireless worked fine on this computer. here is my information.

trav@trav-HP-Pavilion-dv6000-RG360UA-ABA:~$ sudo lshw -C network
  *-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 02
       serial: 00:18:de:76:19:43
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=3.0.0-14-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:43 memory:d6000000-d6000fff
  *-network
       description: Ethernet interface
       product: PRO/100 VE Network Connection
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:05:08.0
       logical name: eth0
       version: 02
       serial: 00:16:36:a3:41:98
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=half firmware=N/A latency=64 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=10Mbit/s
       resources: irq:20 memory:d8000000-d8000fff ioport:4000(size=64)
share|improve this question
    
Is the second trace after you have uninstalled network manager and installed wicd? –  fossfreedom Dec 18 '11 at 22:31
    
correct but i didnt install wicd. I have Ubuntu 10.10 on my USB so i had to delete 11.10 and reinstall 10.10 cause my wireless works on 10.10 then i did the update to 11.10 which i thought would update to wicd but it put gnom network manager back on. So i cannot get online to update wicd. So confused guys –  TRAV Dec 18 '11 at 22:36
    
Somebody suggested i do sudo modprobe iwl3945 dmesg | grep iwl lspci -nn | grep -i wireless what does this do i dont want to do anything i dont know. Could that help my problem? –  TRAV Dec 18 '11 at 22:41
    
do you have a wired connection on your laptop? - you'll need that to do any software package installations. –  fossfreedom Dec 18 '11 at 22:47
    
no sir i do not. Im using my droid mobile hotspot. is it possible for me to download it on my other computer and save it to usb then transfer it over to my Ubunutu if so anyone know how? –  TRAV Dec 18 '11 at 22:52

5 Answers 5

The interesting part of the trace is this:

iwl3945 0000:0b:00.0: Card state received: HW:Kill SW:On

As you also indicated - your rfkill list all results show no hardware/software kill switch issues.

I found this very similar report.

The suggestion was to replace network-manager with wicd (search in software center/synaptic).


There is a bug report for your card on launchpad.

The last entry in the bug report looks promising:

Create a file named config in /etc/pm/config.d/, by doing this:

gksudo gedit /etc/pm/config.d/config

Add this line:

SUSPEND_MODULES="iwl3945".

Save and reboot.

share|improve this answer
    
yes i just uninstalled 11.10 and im reinstalling now. my wireless worked fine on 10.10 im assuming its just an update driver issue im hoping but i cannot get online to update any. Ideas greatly appriciated –  TRAV Dec 18 '11 at 18:27
    
Just my luck lol i tried the keryx site and its down :( I believe this is the answer to my problem tho just wish i can hurry and try it –  TRAV Dec 18 '11 at 23:11
    
You are awesome im trying it as we speak thank you again ok which one do i download? –  TRAV Dec 18 '11 at 23:18
    
also which wicd package –  TRAV Dec 18 '11 at 23:26
    
i have them both on my usb this tutorial is confusing me how do i open them on my ubuntu? –  TRAV Dec 18 '11 at 23:51

Ubuntu 12 corrects the problem.

*-network               
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 02

Slide the wireless switch to the right. Light alternates red/blue.

share|improve this answer

You could search the logs, with something like sudo zegrep -n 'wpa_supplicant|NetworkManager' /var/log/* to see what's going on.

After looking at the posted log, here's how I analyzed it.

Analysis of var_log.txt (http://pastebin.com/Y9s3UJMN), 230 lines like:

/var/log/syslog:7607:Dec 18 14:57:52 trav-HP-Pavilion-dv6000-RG360UA-ABA NetworkManager[870]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]

Too much clutter, and possibly too little information. Let's reduce the clutter, and see what's left. The tool I use for this is the GNU Emacs editor, but you can use any editor on a copy of the file, as did I.

All the lines start with "/var/log/syslog:" - no useful information here, delete.

Next is the line number (due to the -n option). Note that there are gaps in the sequence of line numbers. The omitted lines (7622-7625, and other short gaps) are lines that don't contain "NetworkManager" or "wpa_supplicant", but they might contain interesting information. This is something for you to look at. Let's keep the line numbers, for now.

Then there's the date, time, hostname (what kind of hostname is "trav-HP-Pavilion-dv6000-RG360UA-ABA"? Replace (in the log) it with "trav", with no information lost, and 31 characters of clutter saved per line), and the processname that made the log entry. We only grepped for "NetworkManager" or "wpa_supplicant", so that's all we got. Notice that the PIDs (the Process IDs, in []) remain the same, [870] for NetworkManager, and [916] for wpa_supplicant. This means that NetworkManager and wpa_supplicant did NOT restart during this log fragment. They each think they are functioning "normally".

Finally, we get to the message that was logged. NetworkManager tags its messages with "info" or "warn", wpa_supplicant doesn't.

Then, looking at the messages in the first block of consecutive line numbers, 7607 to 7621:

<info> (wlan0): device state change: need-auth -> prepare (reason 'none')
<info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
<info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.     
<info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting... 
<info> (wlan0): device state change: prepare -> config (reason 'none')
<info> Activation (wlan0/wireless): connection 'Auto Verizon DROIDX 19
<info> Config: added 'ssid' value 'Verizon DROIDX 1980'               
<info> Config: added 'scan_ssid' value '1'                            
<info> Config: added 'key_mgmt' value 'WPA-PSK'                       
<info> Config: added 'psk' value '<omitted>'                          
<info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.   
<info> Config: set interface ap_scan to 1                             
<info> (wlan0): supplicant interface state: inactive -> scanning      
Trying to authenticate with 40:fc:89:29:82:fb (SSID='Verizon DROIDX 19
<info> (wlan0): supplicant interface state: scanning -> authenticating

We see NetworkManager doing Stage 1 and Stage 2 (of 5) of Activation, then calling on wpa_supplicant to try to authenticate using the SSID "Verizon DROIDX 1980", MAC address 40:fc:89:29:82:fb.

Then, at Dec 18 14:58:02 and every 8 seconds thereafter, wpa-supplicant logs:

Trying to authenticate with 40:fc:89:29:82:fb (SSID='Verizon DROIDX 1980' freq=2462 MHz)

Then, at Dec 18 14:58:38, NetworkManager does a 'user-requested' disconnect.

Looking at these log entries was a waste of time - starting over at line 7654 "Activation (wlan0) starting connection 'Verizon DROID2 6182'", but this time, there's some different information:

 <info> Activation (wlan0) starting connection 'Verizon DROID2 6182'
 <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started... 
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.  
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
 <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
 <info> Activation (wlan0/wireless): access point 'Verizon DROID2 6182' has security, but secrets are required.
 <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Then at 14:59:27, we see another wireless restart, still WPA-PSK, known "secrets", but with added 'auth_alg' value 'OPEN'. Different frequency.

 get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
 <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
 <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
 <info> Activation (wlan0/wireless): connection 'Verizon DROID2 6182' has security, and secrets exist.  No new secrets needed.
 <info> Config: added 'ssid' value 'Verizon DROID2 6182'
 <info> Config: added 'scan_ssid' value '1'
 <info> Config: added 'key_mgmt' value 'WPA-PSK'
 <info> Config: added 'auth_alg' value 'OPEN'
 <info> Config: added 'psk' value '<omitted>'
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
 <info> Config: set interface ap_scan to 1
 <info> (wlan0): supplicant interface state: disconnected -> scanning
 Trying to authenticate with f8:7b:7a:4f:8f:56 (SSID='Verizon DROID2 6182' freq=2437 MHz)

Ends up with wpa_supplicant trying a different MAC and SSID, and retrying. At Dec 18 15:00:27 NetworkManager timed out:

 <warn> Activation (wlan0/wireless): association took too long.
 <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
 <warn> Activation (wlan0/wireless): asking for new secrets
 <info> (wlan0): supplicant interface state: authenticating -> disconnected
 <warn> Couldn't disconnect supplicant interface: This interface is not connected.
 get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
 <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
 <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
 <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
 <info> Activation (wlan0/wireless): connection 'Verizon DROID2 6182' has security, and secrets exist.  No new secrets needed.
 <info> Config: added 'ssid' value 'Verizon DROID2 6182'
 <info> Config: added 'scan_ssid' value '1'
 <info> Config: added 'key_mgmt' value 'WPA-PSK'
 <info> Config: added 'auth_alg' value 'OPEN'
 <info> Config: added 'psk' value '<omitted>'
 <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
 <info> Config: set interface ap_scan to 1
 <info> (wlan0): supplicant interface state: disconnected -> scanning
 Trying to authenticate with f8:7b:7a:4f:8f:56 (SSID='Verizon DROID2 6182' freq=2437 MHz)
 <info> (wlan0): supplicant interface state: scanning -> authenticating

then more "Trying to authenticate", restarts, ending up at 15:01:36, "asking for new secrets", and warning "Couldn't disconnect supplicant interface: This interface is not connected." and "No agents were available for this request." which hints at the (lack of) progress of the connection/authentication attempt. NetworkManager gives up on 'Verizon DROID2 6182', marking it invalid.

At Dec 18 15:01:43, NetworkManager auto-activates Verizon DROIDX 1980, but it falls to a 'user-requested' disconnect at 15:02:22.

At 15:02:26 NetworkManager auto-activates Verizon DROIDX 1980 again, until 15:02:40, when "deactivating device (reason 'connection-removed') [38]" happens.

The questions I have at this point are:

Is there any interesting information in lines 7622-7625, and other short gaps?

Why use "40:fc:89:29:82:fb (SSID='Verizon DROIDX 1980' freq=2462 MHz)" and "f8:7b:7a:4f:8f:56 (SSID='Verizon DROID2 6182' freq=2437 MHz)"? Which one is right?

Are you really, really, really sure that you have the WPA pre-shared-key entered correctly? If it's a hex string, try replacing [a-f] with [A-F] or the other way.

Waltinator

share|improve this answer
    
ok sir hope this does it heres the information heres what i get pastebin.com/Y9s3UJMN –  TRAV Dec 18 '11 at 22:50
    
Waltinator i have two mobile hotspots on two differant phones yes i am sure ive tried them both just to check. i will try making sure it isnt a HEX string again i will get back to you asap sorry took me so long to get back on the count i dont have access to a online computer lol.. –  TRAV Dec 21 '11 at 23:01
    
So when i went to edit connections im using WPA & WPA2 security ive tried the pass word numerous times and ive also tried WEP128 Bit Passphrase and WEP 40/128-bit HEX or ASCII. Just Tried the HEX keys maybe im doing it wrong so can you give me an example? im sure im doing it right though –  TRAV Dec 21 '11 at 23:15
    
PLease Help!!! im im dying to use my ubuntu!!! i have a webiste i need to finish lol Thank Everyone for all your help –  TRAV Dec 21 '11 at 23:54

my solution for you dont bother your self so much use 10.04 or 10.10 and stick with it until the next kernel came out, the issue is with the kernel its not only ubuntu that suffer from this i have exact problem and it happen to me with fedora which used the same kernel. i think they have made so crazy change in the drivers in general and thats why we suffer now. i used usb modem and it also suffer low performance it was working so well before i guess this kernel really has so many bugs now. so just wait nothing we can do, unless someone fix this bug in launchpad which is there i did my self report it and here is the link. and its already confirmed https://bugs.launchpad.net/ubuntu/+bug/887317 owh so please add it as affecting you on the launchpad

share|improve this answer
    
That makes sense I've actually thought it was a kernel issue is there anyone we can report this too or do you think they are already working on it? –  TRAV Dec 22 '11 at 16:43
    
i did mention to you if you want to help then report it as affecting you in launchpad. register and then assign it as affecting you too and follow it. then they can look at it if they know that people still affected by it –  nadeem Dec 23 '11 at 14:26

I have encountered a similar one on my notebook and it happened every time its not connected to the charger. It had something to do with the wi-fi power management. Apparently I had to turn it off permanently.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.