Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to tune the permissions on a share I created as a user in Nautilus. This share does not exist in /etc/samba/smb.conf and I can't see where it would be.

Edit: Just found ~/.smb/smb.conf but this doesn't contain any share information, just information, I suspect, that is used to connect to samba servers.

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

Look in /var/lib/samba/usershares/

If you want a graphical interface for samba shares, with a few more options, try system-config-samba

sudo apt-get install system-config-samba

enter image description here

enter image description here

share|improve this answer
    
/var/lib/samba/usershares/ was it! I wanted to add file creation masks (so written files don't end up being owned by nobody or another user) but that doesn't look possible under this configuration format. Might just be easier to hook the share out and stick it in the main samba config. –  Oli Dec 16 '11 at 1:06
1  
Try adding force user = your_user_name to the global section I found that advice on the mint forums forums.linuxmint.com/viewtopic.php?f=49&t=23143 –  bodhi.zazen Dec 16 '11 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.