Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to UBUNTU and have been researching this for awhile now. Still cant seem to come up with any thing. I am in the communications field, so i have a general idea of how things work. I am in Germany and i put the WPA2/personal security code in and it connects.... Click on firefox start browsing and it disconnects starts to reconnect and asks me for the wpa code again. and sometimes dosent even reconnect. i dont have any problems with wired connections.

shannon@shannon-Dell-System-XPS-L502X:~$ lshw -c network
WARNING: you should run this program as super-user.
-network               
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 8c:a9:82:68:7c:7c
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware=39.31.5.1 build 35138 latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:51 memory:f1b00000-f1b01fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: 06
       serial: 14:fe:b5:aa:af:6e
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.2.102 latency=0 multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:2000(size=256) memory:f1804000-f1804fff memory:f1800000-f1803fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.


shannon@shannon-Dell-System-XPS-L502X:~$ sudo rfkill list
0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Any help would be greatly appreciated!!!

share|improve this question
    
please test with the latest ubuntu updates from update manager - a new kernel is available. Also please confirm if this is a WPA specific issue by temporarily turning off your router security. Also test whether by changing your router wireless number from 1 to 6 to 11 affects your disconnection issues. –  fossfreedom Dec 15 '11 at 22:57
add comment

1 Answer 1

There is another thread that worked for me. I had the same problem. Centrino Advanced-N 6230 and bluetooth wireless problems with Dell XPS 15z

Basically login to windows, enable the wireless from there fn+f2. You should see the Wireless led turned on. Reboot in Ubuntu, and voila :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.